Closed Bug 635980 Opened 9 years ago Closed 9 years ago

Frequent harmless ASSERTION Nv3DVStreaming Nv3DVControl failed!

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: benjamin, Assigned: benjamin)

References

Details

Attachments

(1 file)

I keep getting an assertion whenever I open a new window or tab or something: Nv3DVStreaming Nv3DVControl failed!

Somebody in #gfx told me that this was harmless, so I'm providing a patch to turn it into a warning. Or I can remove the debug spew entirely, if that would be better.
Attachment #514288 - Flags: review?(jmuizelaar)
Comment on attachment 514288 [details] [diff] [review]
Change assert to a warning, rev. 1

This is fine. Bas, what causes Nv3DVSetDevice to fail and should we be handling it?
Attachment #514288 - Flags: review?(jmuizelaar) → review+
Comment on attachment 514288 [details] [diff] [review]
Change assert to a warning, rev. 1

This is basically no-risk assertion removal, and the reward is a happy bsmedberg for the life of the branch!
Attachment #514288 - Flags: approval2.0?
Comment on attachment 514288 [details] [diff] [review]
Change assert to a warning, rev. 1

Joe agrees that this is fine.
Attachment #514288 - Flags: approval2.0? → approval2.0+
Duplicate of this bug: 633887
I get this a lot too now that I've upgraded to thet latest NV drivers. Please to be landing?
Landed on trunk
http://hg.mozilla.org/mozilla-central/rev/459f9ea753a2
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Assignee: nobody → benjamin
You need to log in before you can comment on or make changes to this bug.