If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox doesn't take into consideration Vary: X-Requested-With header because tab restore forces load from cache

VERIFIED DUPLICATE of bug 633743

Status

()

Firefox
Session Restore
VERIFIED DUPLICATE of bug 633743
7 years ago
7 years ago

People

(Reporter: Jan Skrasek, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110222 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110222 Firefox/4.0b12pre ID:20110222030357

I sent different contents by the X-Requested-With detection.
However, caching prevent the right behaviour.

See my testcase https://bugzilla.mozilla.org/show_bug.cgi?id=633743

Reproducible: Always

Steps to Reproduce:
1. Sent content by ajax (with X_REQUESTED_WITH=XMLHttpRequest)
2. Access the same url

Actual Results:  
Get cached ajax version of contents

Expected Results:  
Get fresh contents

Updated

7 years ago
Version: unspecified → Trunk
I'm not sure I follow.  The testcase in that bug works for me with these steps:

1)  Load http://temp.skrasek.com/ff/testcase_633743.php
2)  Click the "param 2" link.
3)  Focus url bar and hit enter.

I get "YES" after step 2 and "NO" after step 3.

Are you using some other set of steps?
(Reporter)

Comment 2

7 years ago
The same misbehaving as in the refered bug, but that time I thought it's caused by wrong restoring (by-url-cached) contents. You mentioned, I need to add Vary header, which should prevent before caching that AJAX request.

Steps to reproduce:
1)  Load http://temp.skrasek.com/ff/testcase_633743.php
2)  Click the "param 2" link.
3)  Close the tab
4)  Revert closed tab (CTRL **** T)
That's the same thing as bug 633743. The point is that tab undo always forces a load from the cache, period.  It doesn't allow the networking code to decide whether the cache entry is appropriate to the page or not.

I guess that should be fixed on the Firefox end, if anywhere....
Component: Networking: Cache → Session Restore
Product: Core → Firefox
QA Contact: networking.cache → session.restore
(Reporter)

Comment 4

7 years ago
Well, I agree thats the same bug, but bug 633743 is marked as invalid, so I tried to create another with right error specification, I am unable to change bug header, nevertheless, this bug should by tracked as open.
Uh... you could have just reopened bug 633743...
Summary: Firefox doesn't take into consideration Vary: X-Requested-With header → Firefox doesn't take into consideration Vary: X-Requested-With header because tab restore forces load from cache
Just because a bug is INVALID, doesn't mean it can't be reopened. Please add your justification to bug 633743 if you think it should be reopened.

Marking as DUPE.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 633743
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.