Firefox 4 nightly build frequently terminates abnormally

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: bj, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b12pre) Gecko/20110221 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b12pre) Gecko/20110221 Firefox/4.0b12pre

I recently set Firefox to restore previous sessions by default, and it regularly can't restore the previous session of "about:blank". I thought this was a bug in session restore and reported bug 631882. The response was "Firefox is working correctly, probably an abnormal termination". Since then I've been verifying that the firefox-bin process actually goes away before I shut down my computer (just in case it was exiting too slowly and being killed by the shutdown). but I still keep seeing the messages.

Is any information saved about the nature of the abnormal termination that I can recover to assist in figuring out the problem at exit?

Reproducible: Sometimes

Steps to Reproduce:
1.Set Firefox to restore previous sessions at startup.
2.Close all tabs.
3.Exit Firefox.
4.Verify the firefox-bin process has exited.
5.Reboot computer.
6.Restart Firefox.
Actual Results:  
Sometimes a session restore error is shown, Firefox is "embarrassed" it can't restore
about:blank.

Expected Results:  
about:blank displayed.

Updated

8 years ago
Component: General → Session Restore
QA Contact: general → session.restore
Version: unspecified → Trunk

Comment 1

8 years ago
My bad, re-read the bug properly this time, likely not session restore, moving back to general. Sorry for the bugspam.
Component: Session Restore → General
QA Contact: session.restore → general

Comment 2

8 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

I am unable to reproduce issue.

B.J. can you please try reproducing it using a clean profile, it may be extension related.
(Reporter)

Comment 3

8 years ago
OK, I finally reproduced this. I started with a clean profile, made as few changes as possible, and exited and restarted frequently. The changes I made were:

o Basic state preparation:
  - Turned off primary browser startup check.
  - Sync setup, copy everything but preferences from previous profile.
  - Home page about:blank.
  - Start with pages from previous session.
  - Don't close window when last tab closes.
o After frustration with ads, installed Adblock Plus 1.3.3.
o Turned off warning about opening multiple tabs.
o After frustration with Facebook, installed Better Facebook 5.2.

I am not aware of making other configuration changes, and there was a delay between starting the experiment and each extension install.

So Better Facebook is a candidate. (I also saw the error with Better Facebook 5.3 on my other profile.) I will uninstall Better Facebook and keep monitoring, and contact the extension author.
(Reporter)

Comment 4

8 years ago
It looks like Better Facebook is not the problem. I uninstalled BetterFacebook on the 25th and now run System Monitor to verify that firefox.bin has exited before I shut down the computer.

The only other change I made in my configuration (that I remember) since comment 3 is to configure the tool bars and move some components around.

I am still seeing situations where closed tabs from previous sessions are ignored when I restart, and twice I have started Firefox to see the message:

Well, this is embarrassing.

Minefield is having trouble recovering your windows and tabs. This is usually caused by a recently opened web page.
You can try:
o Removing one or more tabs that you think may be causing the problem
o Starting an entirely new browsing session

Restore Windows and Tabs
        window:1
           about:blank

Comment 5

8 years ago
BJ are you still able to reproduce this issue on the latest trunk?
(Reporter)

Comment 6

8 years ago
I've been using the nightly builds, which have been stuck at 20110303 Firefox/4.0b13pre for a week, and still seeing the issue. I'll be updating to RC1 in a few seconds.
(Reporter)

Comment 7

8 years ago
This morning I got an unable to restore message (from 20110310 Firefox/4.0b13pre) that said it couldn't restore Google News. That was probably the last tab I closed, but i closed my session down to a blank tab before I exited last night.

Comment 8

8 years ago
B.J., are you still seeing this issue?
(Reporter)

Comment 9

8 years ago
Yep. I'm running yesterdays nightly (today's wasn't ready when I left for work this morning) and I just came home from work, started Firefox, and found the message below.

Well, this is embarrassing.
        
Minefield is having trouble recovering your windows and tabs. This is usually caused by a recently opened web page.
          You can try:
            Removing one or more tabs that you think may be causing the problem
            Starting an entirely new browsing session

Restore Windows and Tabs
(check) Window 1
(check)    about:blank


Mozilla/5.0 (X11; Linux x86_64; rv:2.2a1pre) Gecko/20110407 Firefox/4.2a1pre

Comment 10

8 years ago
I also have this kind of behaviour on Windows 7 Pro 64b with FF 4.0.1 (trunk). I have browser.tabs.closeWindowWithLastTab set to false (as mentioned in bug 636053).

Usually I close all tabs before exiting FF. The next time I start FF it comes up with the message from comment 9 (and by now I start to feel it is really embarrassing, since FF is unable to restore about:blank)

Expected result:
Just open my home page as set in the options.

Comment 11

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110711 Firefox/8.0a1

Setting status to New as I've seen this issue several times. It is mostly reproducible when the OS is shut down without first closing Firefox.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 12

6 years ago
I have not seen this issue in over a year.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 13

6 years ago
(In reply to B.J. Herbison from comment #12)
> I have not seen this issue in over a year.

Actually I'm looking at the apology right now. For my feeling I haven't seen it in quite a while, but it started showing up again a couple of times in the few last weeks.

Today I started FF by clicking the link to this bug from TB.
You need to log in before you can comment on or make changes to this bug.