Closed Bug 636143 Opened 9 years ago Closed 9 years ago

Full screen tab bar doesn't drop down after minimize and top of content is cut off.

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 4.0
Tracking Status
blocking2.0 --- -

People

(Reporter: bebef_1987, Assigned: Felipe)

References

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.13 (KHTML, like Gecko) Chrome/9.0.597.98 Safari/534.13
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

After reboot, in full screen mode, if  minimizing and the maximizing FF, the tab bar doesn't drop down

Reproducible: Always

Steps to Reproduce:
1.  Create a new profile on Firefox
2.  Hide the menu bar
3.  Maximize the Firefox window
4.  Press F11 to enter full screen mode
5.  Verify that autohide option works
6.  Exit Firefox
7.  Open Firefox(on the same profile)
8.  Verify that autohide option works
9.  Minimize Firefox
10. Maximize Firefox
11. Verify that autohide option works
Actual Results:  
10. The autohide option doesn't work


Expected Results:  
7.  The Firefox should open in fullscreen mode
10. The autohide function should work
Status: UNCONFIRMED → NEW
Ever confirmed: true
Potentially fixed in bug 616793 which should be in the 2/7 nightly. Can you test the latest to see if this is a dupe?
This is logged on today's Fx4b12 RC build1.
Attached image screenshot
And after restore window from Minimize state, top of content is cut off and scroll arrow is positioned outside screen.
blocking2.0: --- → ?
Keywords: regression
Version: unspecified → Trunk
This also happens on Windows7 Aero/AeroBasic/Classic.
http://hg.mozilla.org/mozilla-central/rev/f8279991d58f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110223 Firefox/4.0b13pre ID:20110223030416
Summary: Full screen tab bar doesn't drop down after minimize → Full screen tab bar doesn't drop down after minimize and top of content is cut off.
Regression range: 

Last good:
http://hg.mozilla.org/mozilla-central/rev/4c62984f12d1
Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre


First bad: 
http://hg.mozilla.org/mozilla-central/rev/3470891975c7
Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110208 Firefox/4.0b12pre

Push log:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4c62984f12d1&tochange=3470891975c7
I reproduced the problem on http://hg.mozilla.org/mozilla-central/rev/4c62984f12d1
Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre

I think this problem happens since the following cset.
For WindowsXP, Classic:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f26255ffe0c9&tochange=a0d6e4d37273
For Windows7Aero:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=94f92b34e535&tochange=f0c025ec62c9
(In reply to comment #6)
> I think this problem happens since the following cset.

This issue was thought to be fixed in bug 616793, which landed after those ranges.

Can you find a regression range after 2011-02-08 or did the fix not work in all cases?
Blocks: 616793
Because this relies on a non-standard configuration (hiding the menuBar on XP) we won't block on it. But really really hope it's fixed!
blocking2.0: ? → -
You can reproduce this simply by:

1) go full screen
2) minimize
3) restore

I'll work up a fix.
Attached patch PatchSplinter Review
This only happens when the browser started in fullscreen mode, right?

Looks like that is the case covered by that if (mFullscreenMode) removed in bug 636143. for some reason GetWindowPlacement returns SW_SHOWNORMAL rather than SW_SHOWMAXIMIZED in this situation
Attachment #514868 - Flags: review?
Assignee: nobody → felipc
Comment on attachment 514868 [details] [diff] [review]
Patch

That fixes the problem. Thanks felipe.
Attachment #514868 - Flags: review?
Attachment #514868 - Flags: review+
Attachment #514868 - Flags: approval2.0?
(In reply to comment #9)
> You can reproduce this simply by:
> 
> 1) go full screen
> 2) minimize
> 3) restore

Does this happen with the menubar showing (the default Win XP toolbar config?)
BTW,
Does this bug cover only windows xp?
See Comment 4, this bug happens on Windows7 Aero.
Should I need create a new bug for Windows7 Aero?
That shouldn't be necessary, this bug should cover them all. I tested the fix on win7 aero.

(Of course, that is assuming that all of the reports here were the same problem.. it's not entirely clear given the different regression ranges posted above)
(In reply to comment #15)

The tryserver build works very well on Windows7 Aero/AeroBasic/Classic.
Comment on attachment 514868 [details] [diff] [review]
Patch

a=beltzner

Please add the in-litmus? flag!
Attachment #514868 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/7da0462c1301
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: in-litmus?
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0
verified on  Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110227 Firefox/4.0b13pre
Status: RESOLVED → VERIFIED
Works For Me on:
Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.