Segfaults with lots of warning messages

RESOLVED DUPLICATE of bug 63529

Status

()

Core
Layout
--
major
RESOLVED DUPLICATE of bug 63529
17 years ago
17 years ago

People

(Reporter: Joseph Wang, Assigned: clayton)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.17-24mdk i686)
BuildID:    20001222

CSSLoaderImpl::DidLoadStyle: Load of URL
'http://demo.horde.org/stable/horde/imp/templates/imp.css' failed.  Error code:
2
###!!! ASSERTION: Channel list is not empty.: 'count == 0', file
nsLoadGroup.cpp, line 269
###!!! Break: at file nsLoadGroup.cpp, line 269
###!!! ASSERTION: Foreground URLs are active.: 'mForegroundCount == 0', file
nsLoadGroup.cpp, line 270
###!!! Break: at file nsLoadGroup.cpp, line 270
CSSLoaderImpl::DidLoadStyle: Load of URL
'http://demo.horde.org/stable/horde/imp/templates/imp.css' failed.  Error code:
2
CSSLoaderImpl::DidLoadStyle: Load of URL
'http://demo.horde.org/stable/horde/imp/templates/imp.css' failed.  Error code:
2
###!!! ASSERTION: Channel list is not empty.: 'count == 0', file nsLoadGroup.cpp
, line 269
###!!! Break: at file nsLoadGroup.cpp, line 269
###!!! ASSERTION: Foreground URLs are active.: 'mForegroundCount == 0', file
nsLoadGroup.cpp, line 270
###!!! Break: at file nsLoadGroup.cpp, line 270
JavaScript strict warning: 
http://demo.horde.org/stable/horde/imp/login.php3?uniq=14147443623a43c2c48d9a8
line 72: reference to undefined property document.all

JavaScript strict warning: 
http://demo.horde.org/stable/horde/imp/login.php3?uniq=14147443623a43c2c48d9a8
line 73: reference to undefined property document.layers

Enabling Quirk StyleSheet
Enabling Quirk StyleSheet
Enabling Quirk StyleSheet
Enabling Quirk StyleSheet
Enabling Quirk StyleSheet
###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().:
'mRawPtr != 0', file ../../dist/include/nsCOMPtr.h, line 648
###!!! Break: at file ../../dist/include/nsCOMPtr.h, line 648

The stack trace looks like

#0  0x40f2b302 in nsWebShell::OnStateChange (this=0x88ae1a8, 
    aProgress=0x86923a4, aRequest=0x0, aStateFlags=393232, aStatus=0)
    at nsWebShell.cpp:905
#1  0x40f821b3 in nsDocLoaderImpl::FireOnStateChange (this=0x8692390, 
    aProgress=0x86923a4, aRequest=0x0, aStateFlags=393232, aStatus=0)
    at nsDocLoader.cpp:1275
#2  0x40f810c8 in nsDocLoaderImpl::doStopDocumentLoad (this=0x8692390, 
    aChannel=0x0, aStatus=0) at nsDocLoader.cpp:717
#3  0x40f80d9e in nsDocLoaderImpl::DocLoaderIsEmpty (this=0x8692390, aStatus=0)
    at nsDocLoader.cpp:622
#4  0x40f80b6c in nsDocLoaderImpl::OnStopRequest (this=0x8692390, 
    aChannel=0x88b7908, aCtxt=0x0, aStatus=0, aMsg=0x0) at nsDocLoader.cpp:554
#5  0x40d5015e in nsLoadGroup::RemoveChannel (this=0x86d0d08, 
    channel=0x88b7908, ctxt=0x0, aStatus=0, aStatusArg=0x0)
    at nsLoadGroup.cpp:576
#6  0x413a3b53 in PresShell::RemoveDummyLayoutRequest (this=0x87c5d68)
    at nsPresShell.cpp:5335
#7  0x413a3794 in PresShell::ReflowCommandRemoved (this=0x87c5d68, 
    aRC=0x88b74f8) at nsPresShell.cpp:5286
#8  0x413a308f in PresShell::ProcessReflowCommands (this=0x87c5d68, 
    aInterruptible=1) at nsPresShell.cpp:5107
#9  0x4168f90c in ReflowEvent::HandleEvent (this=0x88b7ac0)
    at nsPresShell.cpp:4986
#10 0x413a2bde in HandlePLEvent (aEvent=0x88b7ac0) at nsPresShell.cpp:5002
#11 0x401293ec in PL_HandleEvent ()
    at ../../../dist/include/nsIPageSequenceFrame.h:112
#12 0x401291e9 in PL_ProcessPendingEvents ()
    at ../../../dist/include/nsIPageSequenceFrame.h:112
#13 0x4012b250 in nsEventQueueImpl::ProcessPendingEvents ()
    at ../../../dist/include/nsIPageSequenceFrame.h:112
#14 0x40777d34 in event_processor_callback ()
    at ../../../dist/include/nsIPageSequenceFrame.h:112
#15 0x40777903 in our_gdk_io_invoke ()
    at ../../../dist/include/nsIPageSequenceFrame.h:112
#16 0x40957cd9 in g_io_unix_dispatch ()
    at ../../../dist/include/nsIPageSequenceFrame.h:112

The listing of the problem is 

905	      (void) channel->GetURI(getter_AddRefs(url));

Channel is created by 

 nsCOMPtr<nsIChannel> channel(do_QueryInterface(aRequest));

and aRequest is NULL

(gdb) print aRequest
$3 = (nsIRequest *) 0x0


Reproducible: Always
Steps to Reproduce:
1. Look at referenced web page
2.
3.

Comment 1

17 years ago
Confirming crash loading given URL on Linux and WinNT 20001221xx builds. 
Changing OS to "All". 


No JS Engine issues apparent in stack trace; reassigning to Layout
for further triage -


Note: my Linux and WinNT binaries 20001209xx do NOT crash on load.
So it looks like the bug was introduced between 2000-12-09 and 2000-12-21.
Assignee: rogerl → clayton
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Layout
Ever confirmed: true
Keywords: crash
OS: Linux → All
QA Contact: pschwartau → petersen

Comment 2

17 years ago
I get a crash in MTrunk 2000122212 for MacOS.

All/All
Severity: normal → major
Hardware: PC → All

Comment 3

17 years ago
looks like 63529

*** This bug has been marked as a duplicate of 63529 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.