Last Comment Bug 636370 - Port |Bug 437657 - increase autocompact threshold "mail.purge_threshhold"| to SeaMonkey
: Port |Bug 437657 - increase autocompact threshold "mail.purge_threshhold"| to...
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Account Configuration (show other bugs)
: Trunk
: All All
: -- minor (vote)
: seamonkey2.1b3
Assigned To: Jens Hatlak (:InvisibleSmiley)
:
Mentors:
: 636373 (view as bug list)
Depends on: 437657
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 19:14 PST by Serge Gautherie (:sgautherie)
Modified: 2011-03-15 17:13 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
b3+


Attachments
patch [Checkin: comment 6] (5.82 KB, patch)
2011-02-24 08:50 PST, Jens Hatlak (:InvisibleSmiley)
mnyromyr: review+
mozilla: superreview+
Details | Diff | Review

Description Serge Gautherie (:sgautherie) 2011-02-23 19:14:52 PST
That bug changed TB value unit to MB from KB.

"blocking-seamonkey2.1=?":
As this impacts strings, SM should do it before 2.1b3, if we want to sync' (in 2.1 cycle).
Comment 1 Philip Chee 2011-02-23 21:44:10 PST
*** Bug 636373 has been marked as a duplicate of this bug. ***
Comment 2 Philip Chee 2011-02-23 21:45:45 PST
> David :Bienvenu      2011-01-12 17:08:48 PST

> Created attachment 503351 [details] [diff] [review]
> turn on autocompact by default, switch to MB
> 
> This patch does several things:
> 
> Turn on autocompact by default
> For TB, migrate the pref to MB, and migrate old pref
> Fix the options UI to use the new pref in MB
> switch the default to 20MB, if the user hasn't changed the threshold.
> 
> This leaves SM using the old pref, but if they fix their preferences UI to use
> MB's, we can turn on the backend code for them.
Comment 3 Jens Hatlak (:InvisibleSmiley) 2011-02-23 22:55:08 PST
So they didn't turn on autocompact just yet, which is good (see below). I don't see any problem with porting the first (prefs/UI) part and removing the ifdefs, though. Karsten?

The reason why I have a problem with autocompacting (and the reason why I turned it off for me eventually after I had it activated for quite some time) is that it seems to throw away the current view, leaving you with an empty thread pane (at least that's what I recall from memory using SM 2.0; I neither checked SM trunk nor Shredder yet). Actually that happens whenever you compact a folder you're currently viewing, but with autocompacting it happens out of the blue (for anyone who doesn't know that it's due to compacting that is, but that's probably the majority of users).
Comment 4 Jens Hatlak (:InvisibleSmiley) 2011-02-24 08:50:53 PST
Created attachment 514808 [details] [diff] [review]
patch [Checkin: comment 6]

Will ask bienvenu for sr once we have an r+.
Comment 5 David :Bienvenu 2011-03-14 16:15:33 PDT
Comment on attachment 514808 [details] [diff] [review]
patch [Checkin: comment 6]

cool, thx for getting to this so promptly.
Comment 6 Jens Hatlak (:InvisibleSmiley) 2011-03-15 12:49:04 PDT
Comment on attachment 514808 [details] [diff] [review]
patch [Checkin: comment 6]

http://hg.mozilla.org/comm-central/rev/f64fe11636ed
Comment 7 Serge Gautherie (:sgautherie) 2011-03-15 17:13:30 PDT
(In reply to comment #3)
> So they didn't turn on autocompact just yet, which is good (see below).

Ftr, iiuc, they did turn autocompact (prompt) on with their (shared) second patch.

Note You need to log in before you can comment on or make changes to this bug.