Closed Bug 636449 Opened 9 years ago Closed 9 years ago

Multitouch gestures scroll to wrong bottom/ top of page

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ioana.chiorean, Assigned: mbrubeck)

Details

(Keywords: polish, Whiteboard: [has patch])

Attachments

(2 files)

Attached image bottom
Build id : Mozilla/5.0 (Maemo;Linux armv7l;rv:2.0b12pre)Gecko/20110224
Firefox/4.0b12pre Fennec /4.0b6pre
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1

Steps to reproduce:
Go to Planet Mozilla
Position two fingers on the screen and move them up quickly
Position two fingers on the screen and move them down quickly

Expected result:
-  when finger are moved down - the page is scrolled to the bottom, when fingers are moved up -the page is scrolled to the top. No URL bar should be seen

Actual result:
- the bottom part where the gesture brings you is upper to the real bottom line, and when scroll to the top, the URL is present, which it shouldn't.
Assignee: nobody → mbrubeck
Keywords: polish
Attached patch patchSplinter Review
Very simple fix.
Attachment #516948 - Flags: review?(21)
Whiteboard: [has patch]
Status: NEW → ASSIGNED
Do you plan to ask approval for this bug?
Comment on attachment 516948 [details] [diff] [review]
patch

Mark, can I land this for Fennec 4.0?  (One-line change to add a hideTitlebar() call in a place where we want to hide the titlebar.)
Attachment #516948 - Flags: feedback?(mark.finkle)
Attachment #516948 - Flags: feedback?(mark.finkle)
http://hg.mozilla.org/mobile-browser/rev/edd4fb92ff06
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b13pre) Gecko/20110316
Firefox/4.0b13pre Fennec /4.0b6pre
Device: HTC Desire

When I scroll to the top, the URL bar still appears.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #5)
> When I scroll to the top, the URL bar still appears.

This is intentional - I left that in, because I use this gesture as a quick way to show the urlbar.  (Sorry, I should have mentioned this when I posted the patch, since comment 0 says otherwise.)
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Oh, ok then verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.