Last Comment Bug 636538 - Remove xul: prefixes in createElementNS calls in HUDService.jsm
: Remove xul: prefixes in createElementNS calls in HUDService.jsm
Status: RESOLVED FIXED
[good first bug] [cleanup] [console-1]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 8
Assigned To: Rob Campbell [:rc] (:robcee)
:
Mentors:
Depends on:
Blocks: consolecleanup
  Show dependency treegraph
 
Reported: 2011-02-24 11:58 PST by Rob Campbell [:rc] (:robcee)
Modified: 2011-07-28 09:57 PDT (History)
3 users (show)
gavin.sharp: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
[in-fx-team] remove xul: (6.70 KB, patch)
2011-07-26 12:07 PDT, Rob Campbell [:rc] (:robcee)
bugzilla: review+
Details | Diff | Splinter Review

Description Rob Campbell [:rc] (:robcee) 2011-02-24 11:58:34 PST
There are between 11 and 12 occurrences (depending on which patches are installed) of createElementNS(XUL_NS, "xul:tagname") in HUDService.jsm. The xul: prefix is at best a no-op since we're specifying the namespace. We should remove them based on Dao's comment in:

https://bugzilla.mozilla.org/show_bug.cgi?id=611795#c54
Comment 1 Rob Campbell [:rc] (:robcee) 2011-07-26 12:04:07 PDT
taking this as a follow-up to bug 662807.
Comment 2 Rob Campbell [:rc] (:robcee) 2011-07-26 12:07:39 PDT
Created attachment 548537 [details] [diff] [review]
[in-fx-team] remove xul:
Comment 3 David Dahl :ddahl 2011-07-26 12:10:32 PDT
Comment on attachment 548537 [details] [diff] [review]
[in-fx-team] remove xul:

Awesome. More of my clutter is being removed!
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-07-28 09:57:32 PDT
http://hg.mozilla.org/mozilla-central/rev/a2690a2d6270

Note You need to log in before you can comment on or make changes to this bug.