[Mac] Firefox 4.0b13pre crash [@ mozilla::layers::ImageLayerOGL::RenderLayer ]

VERIFIED FIXED in Firefox 6

Status

()

Core
Graphics
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: d.a., Assigned: BenWa)

Tracking

({crash, topcrash})

unspecified
mozilla7
x86
Mac OS X
crash, topcrash
Points:
---

Firefox Tracking Flags

(firefox6 fixed, firefox7 fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b13pre) Gecko/20110224 Firefox/4.0b13pre
Build Identifier: 

I got this crash after watching a 720p video on YouTube in fullscreen, and going to a new video.

STR:
1. Load up a few videos in the video queue, may need to have an 720p video among them.
2. Set the player to view the 720p version of the video.
3. Go to fullscreen and watch the video.
4. Exit full screen.
5. Go to the next video in the queue.

Firefox should now crash.

Crash reports:
https://crash-stats.mozilla.com/report/index/bp-0c83142a-5207-4ad0-ba8d-88da82110225
https://crash-stats.mozilla.com/report/index/bp-2792304a-4766-4d02-9120-a3fb72110224

Reproducible: Always
Haven't yet been able to reproduce your crash usingMozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b13pre) Gecko/20110225 Firefox/4.0b13pre. Are there any other steps you are doing between steps 4 and 5?
(Reporter)

Comment 2

6 years ago
No extra step between step 4 and 5, but on both occasions Firefox had been used for a while (more than 30 minutes). I think there must be something must happen before step 1 for the crash to happen.

Comment 3

6 years ago
It is #15 top crasher on Mac OS X in 4.0b12.

Here are some comments:
"Was using Command+- to reduce the side of a page which contained a Flash video."
"crashed closing a tab with quicktime player streaming an mp3 in it"
"crash appeared during debugging session of adobe flex application."
"Reading reddit, just installed reddit enhancement suite, the greasemonkey script, which made firefox a bit laggy, and I was just scrolling down when it crashed."
"I was just randomly surfing the web, I clicked on Adium to answer an IM and firefox just straight up crashed."

More reports at:
https://crash-stats.mozilla.com/report/list?product=Firefox&range_value=4&range_unit=weeks&signature=mozilla%3A%3Alayers%3A%3AImageLayerOGL%3A%3ARenderLayer
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

6 years ago
It is #7 top crasher on Mac OS X in 4.0RC1.
Keywords: crash, topcrash
happened to me without full-screen
Crashed in this stack while trying to reproduce Bug 637367.
I just got this crash while trying to download an mp3 (I presume into the QuickTime plugin). bp-adda619d-d07d-4abe-8bed-e34042110429
I crashed in this stack while I was not using the browser running 4.0.1. Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
http://tinyurl.com/3ccazon indicates 512 crashes in the last week across all versions. Many of the crash comments do specifically mention flash. One of the tabs I had open at the time of the crash was hulu.com.
Crash Signature: [@ mozilla::layers::ImageLayerOGL::RenderLayer ]

Comment 10

6 years ago
Benoit - can you take a look at this?
Assignee: nobody → bgirard
(Assignee)

Comment 11

6 years ago
I though it might be related to bug 641227 but this problem was reported before.

Still investigating.
(Assignee)

Comment 12

6 years ago
Created attachment 543763 [details] [diff] [review]
Check for null MacIOSurfaceImageOGL. v1
Attachment #543763 - Flags: review?(matt.woodrow+bugzilla)
(Assignee)

Comment 13

6 years ago
Comment on attachment 543763 [details] [diff] [review]
Check for null MacIOSurfaceImageOGL. v1

Null Pointer check will fix a top crashers, we should land this on aurora/beta.
Attachment #543763 - Flags: approval-mozilla-beta?
Attachment #543763 - Flags: approval-mozilla-aurora?
Attachment #543763 - Flags: review?(matt.woodrow+bugzilla) → review+
(Assignee)

Updated

6 years ago
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/c97d7a25a921
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
status-firefox7: --- → fixed
Whiteboard: [inbound]

Updated

6 years ago
Attachment #543763 - Flags: approval-mozilla-beta?
Attachment #543763 - Flags: approval-mozilla-beta+
Attachment #543763 - Flags: approval-mozilla-aurora?
Attachment #543763 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 15

6 years ago
The patch is already on aurora because it landed before the merge, checkin needed for beta.
Keywords: checkin-needed
(Assignee)

Updated

6 years ago
status-firefox6: --- → affected
http://hg.mozilla.org/releases/mozilla-beta/rev/7e4bc2255cfb
status-firefox6: affected → fixed
Keywords: checkin-needed
Target Milestone: --- → mozilla7

Updated

6 years ago
Attachment #543763 - Flags: approval-mozilla-aurora+

Comment 17

6 years ago
Verified fixed on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0

There is no error / crash while playing highres videos from a youtube playlist, toggling fullscreen and normal window.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.