Netscape 6 hangs hitting OK in Preferences

VERIFIED DUPLICATE of bug 58417

Status

SeaMonkey
Passwords & Permissions
VERIFIED DUPLICATE of bug 58417
18 years ago
14 years ago

People

(Reporter: Hal Goldfarb, Assigned: Stephen P. Morse)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I queried the bug base a few times, but did not find a match for this.

In the ISP email login dialog box, there is a checkbox to have the program
remember the password.  I selected it, and the program suggested that I may want
to use encryption when storing sensitive data.  I'm a guy who's into some
security, so I decided to do that.

I opened the preferences and went to the advanced/password tab. Being that I am
also a guy who's curious what this might do, I hit the button "view saved
passwords" and viola!  there was the entry for the ISP mail login.  So, I
figured, maybe I better delete the entry or it could end up being one of the
unfortunate ones that are not encrypted.  Then I exited from that, hit the
button "use encryption when storing sensitive data", then hit OK.

All of the windows netscape had open hung (graphics did not get updated). All
the other programs were operating fine.  I killed off all of the windows using
kpm.  Then I repeated this exercise 2 more times before deciding to send you
this bug report.

I am running SuSE 6.3 Linux (2.2.13 kernel) with the old KDE (I think 1.1.2 plus
some attempted upgrades to some of the KDE programs) on a Pentium II 450 with
256MB and plenty of disk space. I will be upgrading to Mandrake 7.2 hopefully
before years end, so I may not be able to test a fix if the problem is distro
specific.  Hopefully this bug is more general than my platform.

As I am a guy who cares about open software and its development, please feel
free to contact me with more questions.  I am even willing to do a walkthrough
by phone if that would support your efforts.

Yours,
Hal Goldfarb
206 256 6171 (home)
206 498 9867 (cell/vm)
codewell@reflexnet.net
Works for me with 2000121904 / Win2k.

Reporter: Are you using the commercial Netscape 6 ?
If yes you should use http://help.netscape.com/forms/bug-client.html to report
NS6 bugs. (See also http://www.mozilla.org/quality/help/bugzilla-helper.html)
If you can reproduce this with a Mozilla build, please poste the build # from 
the titlebar.

Thanks

Comment 2

18 years ago
Worksforme buildID 2000122320 win32. Created a mail account, hit "get msg", was
prompted for my password, checked "remember this password", hit ok. Then I went
to preferences|advanced|passwords and checked "use encryption when storing
sensitive data". Clicked OK. A PSM window opened asking for a master password.
Hit OK. Hit "view saved passwords" in the password manager and got my password
with a (encrypted) flag. Looks definitely correct. Anything I did wrong to
reproduce your bug?
(Assignee)

Comment 3

18 years ago
It's often difficult, if not outright impossible, to find a match in the bug 
report before reporting a new one.  But this one is there -- it's bug 58417.

See the details in that report for when this bug strikes and what the 
work-around is.  Basically, if you had previously established a master password, 
you won't get the hang.  I suspect that's why the others were not able to 
reproduce it.

Regarding the deletion of the existing ISP login, that wasn't necessary.  Once 
you selected to use encryption, all previously collected logins will 
automatically get encrypted. 

*** This bug has been marked as a duplicate of 58417 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.