Download window does not draw correctly

NEW
Unassigned

Status

()

Core
Graphics
7 years ago
4 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 515353 [details]
[screenshot] Firefox failed to draw download window properly

A) Steps to reproduce:
1. Choose a big file to download
2. Download window opens

B) Steps to reproduce:
1. Ctrl + J brings the download window

Noticeable bug:
* Unless you hover over the "clear" button and the "search" field you won't see them drawn

Noticeable drawn order:
* If you pay attention closely you can see 1) the window (outer area) being drawn, then 2) the button and search field at the bottom and then 3) the files that have been downloaded. The problem is when number 3 happens it actually makes the clear button and the search field to dissapear

Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

    DirectX Version: DirectX 11
   Operating System: Windows 7 Professional 64-bit (6.1, Build 7600) (7600.win7_gdr.101026-1503)
               BIOS: BIOS Date: 08/23/10 14:48:45 Ver: 08.00.14
          Processor: AMD Phenom(tm) 9750 Quad-Core Processor (4 CPUs), ~2.4GHz
          Card name: NVIDIA GeForce 7025 / NVIDIA nForce 630a
     Display Memory: 1912 MB
   Dedicated Memory: 248 MB
      Shared Memory: 1663 MB
       Current Mode: 1920 x 1200 (32 bit) (59Hz)
        Native Mode: 1920 x 1200(p) (59.950Hz)
        Driver Name: nvd3dumx.dll,nvd3dum
Driver File Version: 8.17.0012.6658 (English)
        DDI Version: 9Ex
       Driver Model: WDDM 1.0
   Driver Date/Size: 1/7/2011 22:27:00, 12859496 bytes
        WHQL Logo'd: Yes
  Device Identifier: {D7B71E3E-4096-11CF-F169-A8A31CC2C535}
          Vendor ID: 0x10DE
          Device ID: 0x03D6
          SubSys ID: 0x83A41043
        Revision ID: 0x00A2
 Driver Strong Name: oem16.inf:NVIDIA_SetB_Devices.NTamd64.6.0:Section001:8.17.12.6658:pci\ven_10de&dev_03d6
     Rank Of Driver: 00E62001
Could you include your graphics info from about:support?
(Reporter)

Comment 2

7 years ago
Graphics
########
Adapter Description      NVIDIA GeForce 7025 / NVIDIA nForce 630a
Vendor ID                10de
Device ID                03d6
Adapter RAM              256
Adapter Drivers          nvd3dumx,nvd3dum
Driver Version           8.17.12.6658
Driver Date              1-7-2011
Direct2D Enabled         false
DirectWrite Enabled      false (6.1.7600.16699, font cache n/a)
WebGL Renderer           Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows  1/1 Direct3D 9
(Reporter)

Comment 3

7 years ago
This is still happening.
blocking2.0: --- → ?

Comment 4

7 years ago
Changing platform to x86; since WOW64 in user agent indicates 32bit build of Firefox (platform refers to browser build, not OS).
Hardware: x86_64 → x86

Comment 5

7 years ago
I'm unable to reproduce this on Windows 7 with today's nightly build. I've tested with several existing items in the download window and after clearing the list so only the current download is displayed and I cannot reproduce in either case. 

Adapter Description:  Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID:  8086
Device ID:  2a42
Adapter RAM:  Unknown
Adapter Drivers:  igdumdx32 igd10umd32
Driver Version:  8.15.10.2202
Driver Date:  8-25-2010
Direct2D Enabled:  true
DirectWrite Enabled:  true (6.1.7600.20830, font cache 31.62 MB)
WebGL Renderer:  Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows:  1/1 Direct3D 10
(Reporter)

Comment 6

7 years ago
I am still hitting it with:
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110302 Firefox/4.0b13pre

Could it be related that I have D2D disabled and my machine uses Direct3D 9?

Asa were you able to reproduce the problem previously?

bjacob do you know why DirectX 9 gets used on my machine if Directx 11 shows as installed?

Windows 7 Professional 64-bit (6.1, Build 7600) (7600.win7_gdr.101026-1503)
(In reply to comment #6)
> I am still hitting it with:
> Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre)
> Gecko/20110302 Firefox/4.0b13pre
> 
> Could it be related that I have D2D disabled and my machine uses Direct3D 9?
> 
> Asa were you able to reproduce the problem previously?
> 
> bjacob do you know why DirectX 9 gets used on my machine if Directx 11 shows as
> installed?

We can only use either D3D 9 or 10. Many intel cards seem to have trouble with D3D 10 initialization; when they fail, we fall back to D3D 9.
I can confirm the issue on Direct3D 9 layers on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110301 Firefox/4.0b13pre

In my case the button and searchfield are only partially cropped.
Questions to anybody who can reproduce:
  - try setting layers.acceleration=disabled. Does that fix it?
  - if it doesn't, paste the contents of the graphics section in about:support (-> Marco)
(In reply to comment #9)
> Questions to anybody who can reproduce:
>   - try setting layers.acceleration=disabled

I mean layers.acceleration.disabled=true
We'd take the patch on the branch, likely, but not blocking the release on it.
blocking2.0: ? → -
(Reporter)

Comment 12

7 years ago
(In reply to comment #10)
> (In reply to comment #9)
> > Questions to anybody who can reproduce:
> >   - try setting layers.acceleration=disabled
> 
> I mean layers.acceleration.disabled=true

When it is disabled I don't have the problem.
You need to log in before you can comment on or make changes to this bug.