iframe embedding youtube not displaying in os x

VERIFIED FIXED

Status

()

Core
Graphics
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: dherman, Assigned: mattwoodrow)

Tracking

({regression})

Trunk
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [hardblocker][has patch], URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
I updated to the latest nightly and tried again, but the embedded video at this page is still not displaying:

http://blog.fishbone.net/everyday-sunshine-the-story-of-fishbone-offic

It starts playing but there's no video. I'm on a MB Pro, OS X 10.6.6.

When I go to the actual YouTube link the video plays fine.

Dave
The product "Firefox" is basically only the Userinterface of the browser. A problem with the content of a website is in most cases the product "Core".

wfm with Seamonkey trunk on win32, OS X only ?
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: 3.6 Branch → Trunk
(Reporter)

Comment 2

7 years ago
> The product "Firefox" is basically only the Userinterface of the browser. A
> problem with the content of a website is in most cases the product "Core".

My bad -- still learning the products and components.

> wfm with Seamonkey trunk on win32, OS X only ?

I only have a Mac available to me right now, so I can't try it out elsewhere. Just to make sure, I reinstalled Flash and the site is still not working. It is working in other browsers, so it's not a bug in the site, or at least not an obvious one.

Dave
I can reproduce this on Mac.  The problem goes away if I disable GL acceleration.
Created attachment 515650 [details]
Minimalish testcase

The text is needed.  The bug also reproduces if I wrap a <div> around the text, as in the original site, but just using a fixed-height <div> does NOT show the bug.

The background image is arbitrary; it being fixed is required, though.
And this is a somewhat recent regression.
blocking2.0: --- → ?
Component: Plug-ins → Graphics
Keywords: regression
QA Contact: plugins → thebes
This is WFM on OSX, latest nightly. Boris: can you still reproduce?
In order to reproduce you have to be not in the YouTube HTML5 beta.
Assignee: nobody → matt.woodrow+bugzilla
blocking2.0: ? → final+
Whiteboard: [hardblocker]
And you have to have GL acceleration actually enabled.

And yes, I can reproduce on today's nightly.
(Assignee)

Comment 10

7 years ago
Created attachment 515777 [details] [diff] [review]
Reset the active texture

Thanks for the testcase bz! (especially noticing that the fixed background caused it).

Thebes layers with component alpha were changing the active texture to GL_TEXTURE1 and never resetting it.

This makes us explicitly bind the texture we want for MacIOSurfaceImages and reset it in ThebesLayer. We don't really need both, but I don't see the harm.
Attachment #515777 - Flags: review?(joe)
(Assignee)

Updated

7 years ago
Whiteboard: [hardblocker] → [hardblocker][has patch]

Comment 11

7 years ago
Comment on attachment 515777 [details] [diff] [review]
Reset the active texture

Can this be tested automatically using the test plugin, and perhaps a white background image?
(Assignee)

Comment 12

7 years ago
Our test plugin doesn't use core animation and wouldn't hit this bug sadly. That may be an issue in it's own right.
Comment on attachment 515777 [details] [diff] [review]
Reset the active texture

no-brainer
Attachment #515777 - Flags: review?(joe)
Attachment #515777 - Flags: review+
Attachment #515777 - Flags: approval2.0+
(Assignee)

Comment 14

7 years ago
http://hg.mozilla.org/mozilla-central/rev/65c1d9309c57
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified on Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.