Last Comment Bug 637049 - No GUI to return from fullscreen mode with popups
: No GUI to return from fullscreen mode with popups
Status: VERIFIED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 6
Assigned To: Christian Ascheberg
:
Mentors:
https://bug586212.bugzilla.mozilla.or...
: 615522 (view as bug list)
Depends on:
Blocks: 575516
  Show dependency treegraph
 
Reported: 2011-02-26 12:44 PST by Christian Ascheberg
Modified: 2013-12-27 14:35 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
patch (1.81 KB, patch)
2011-02-27 13:16 PST, Christian Ascheberg
dao+bmo: review+
Details | Diff | Splinter Review

Description Christian Ascheberg 2011-02-26 12:44:56 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b13pre) Gecko/20110226 Firefox/4.0b13pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b13pre) Gecko/20110226 Firefox/4.0b13pre

When opening 'toolbar=0' popup in fullscreen mode, caption buttons will not be displayed in the GUI anymore

Reproducible: Always

Steps to Reproduce:
1. open URL above
2. click link
3. in popup: click Minefield-Button > Fullscreen (or press F11)
4. move mouse to top of the screen
Actual Results:  
only urlbar will be shown, no caption buttons

Expected Results:  
caption buttons should be displayed also, as people might not know the keyboard shortcuts
Comment 1 Christian Ascheberg 2011-02-26 12:50:59 PST
only happens with tabs-on-top
Comment 2 Asa Dotzler [:asa] 2011-02-26 15:36:32 PST
same issue as bug 615522 I suspect. pretty darned sure this isn't going to block the release.
Comment 3 Dietrich Ayala (:dietrich) 2011-02-27 08:50:45 PST
We can fix this in a security/stability release, not severe enough to hold back Firefox 4. Would definitely consider a safe patch if it materializes before Fx4 ships though.
Comment 4 Christian Ascheberg 2011-02-27 13:16:53 PST
Created attachment 515509 [details] [diff] [review]
patch

In these cases the window controls can / should be displayed in the tab bar:
1.: document.documentElement.getAttribute("chromehidden").indexOf("toolbar") == -1
 -> check that it is *not* a javascript popup with 'toolbar=0', where the tab bar is hidden
 
2.: navbar.collapsed
 -> user chose option to hide navbar (should fix bug 615522), so use tab bar
 
3.: TabsOnTop.enabled
 -> as before: use tab bar when tabs-on-top, check that tab bar does not autohide
    (I think ideally it should not only check for the pref, but if nav-bar is actually hidden (collapsed), but that would have to be updated whenever a tab is opened or closed)

There is still no check if there is at least the tab bar or the url bar visible at all.
Comment 5 Christian Ascheberg 2011-03-23 13:23:45 PDT
can somebody at least confirm this bug and maybe even look at the few lines short patch?
Comment 6 Asa Dotzler [:asa] 2011-03-23 13:48:20 PDT

*** This bug has been marked as a duplicate of bug 615522 ***
Comment 7 Asa Dotzler [:asa] 2011-03-23 13:49:19 PDT
Oops, duped the wrong way.
Comment 8 Asa Dotzler [:asa] 2011-03-23 13:49:33 PDT
*** Bug 615522 has been marked as a duplicate of this bug. ***
Comment 9 Dão Gottwald [:dao] 2011-04-16 16:36:43 PDT
Comment on attachment 515509 [details] [diff] [review]
patch

>+    var navbar = document.getElementById("nav-bar");
>+    var ctlsOnTabbar = document.documentElement.getAttribute("chromehidden")
>+                            .indexOf("toolbar") == -1 &&

This should be replaced with window.toolbar.visible.

>     if (fullscreenctls.parentNode.id == "nav-bar" && ctlsOnTabbar) {

Now that you have the navbar reference, you could compare it directly with fullscreenctls.parentNode.

Looks good otherwise, thanks!
Comment 10 Dão Gottwald [:dao] 2011-04-17 10:34:25 PDT
http://hg.mozilla.org/mozilla-central/rev/2e7f1fb3ce4c

(I made the two changes from comment 9.)
Comment 11 Christian Ascheberg 2011-04-18 07:20:35 PDT
(In reply to comment #10)
> http://hg.mozilla.org/mozilla-central/rev/2e7f1fb3ce4c
> 
> (I made the two changes from comment 9.)

Thank you!

Note You need to log in before you can comment on or make changes to this bug.