If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

regression: menulist popups don't show checkmarks

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

({regression})

Trunk
regression

Details

(Whiteboard: [has patch])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 years ago
Steps to reproduce:
Tap on the "home page" or "language" menu in the Fennec prefs.

Expected results: A checkmark next to the currently selected item.

Actual results: no checkmark.

Regression from bug 622578.
(Assignee)

Comment 1

7 years ago
Created attachment 515527 [details] [diff] [review]
patch

We used to use ".menulist-command.selected".  Now it should be ".option-comand[selected=true]".
Attachment #515527 - Flags: review?(21)
(Assignee)

Updated

7 years ago
Whiteboard: [has patch][needs review]
Comment on attachment 515527 [details] [diff] [review]
patch

I thought we were moving to use the "selected" class name, since the "selected" attribute is controlled by the listbox/richlistbox XBL bindings.
(Assignee)

Comment 3

7 years ago
Created attachment 515555 [details] [diff] [review]
patch v2

Use the .selected class.  Also found a .menulist-command selector that wasn't caught before.
Attachment #515527 - Attachment is obsolete: true
Attachment #515527 - Flags: review?(21)
Attachment #515555 - Flags: review?(21)
Attachment #515555 - Flags: review?(21) → review+
(Assignee)

Comment 4

7 years ago
http://hg.mozilla.org/mobile-browser/rev/93f97ccc6916
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Whiteboard: [has patch][needs review] → [has patch]

Comment 5

7 years ago
Please see http://www.youtube.com/watch?v=tQVV-m1WAHc 

Build id: Mozilla/5.0 (Android;Linux armv7l;rv:2.0b13pre)Gecko/20110228
Firefox/4.0b13pre Fennec /4.0b6pre 

Actual result: 
- some languages are hard to be checked (eg Portuguese)
- at home page and language doesn't keep the current selected option.

due to the above facts, I will reopen the bug
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 6

7 years ago
Build id: Mozilla/5.0 (Android;Linux armv7l;rv:2.0b13pre)Gecko/20110301
Firefox/4.0b13pre Fennec /4.0b6pre 

On today's new build everything works fine, The check mark remains at the selected option.
Sorry for comment 5.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Comment 7

7 years ago
Due to comment 6 I will mark the bug as verified fixed
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.