Closed Bug 637368 Opened 9 years ago Closed 6 years ago

spirit.com - the list of departing flight locations doesn't come up

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jbecerra, Unassigned)

References

()

Details

(Keywords: regression)

Someone in #qa reported this problem and mentioned that it was working in the last beta, but then the problem reappeared.

This works on 3.6.x, and other people mentioned it works in IE and Chrome, but it doesn't work on the latest nightly nor Fx4b3, for instance. I didn't try any older betas.

The error console shows a few errors like:

Error: assignment to undeclared variable SKYSALES
Source File: http://www.spirit.com/js/Base/common_original.js
Line: 119

I can't tell if this is a site issue, but since it works in 3.6.x and it's functionality commonly used, I'm nominating for blocking so we can at least put it in the right bucket.
--> Core::JS based on the error message
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
view-source:http://www.spirit.com/js/Base/common_original.js shows 'use strict'; slapping on without testing, as a warding sign against who-knows-what. It brought bad luck.

Browsers supporting ES5 strict:

http://kangax.github.com/es5-compat-table/

Chrome (V8) support is coming. IE9 is rumored.

The site needs to remove this 'use strict' directive or fix the strict-mode bugs by testing (with all paths coverage) in Firefox.

/be
Assignee: general → english-us
Component: JavaScript Engine → English US
Product: Core → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
Conforming summary to TE guidelines.

Juan: If this comes up again on IRC, please encourage the complainant to take this up with Spirit Airlines and point their IT department to this bug.
Hardware: x86 → All
Summary: the list of departing flight locations doesn't come up → spirit.com - the list of departing flight locations doesn't come up
Assignee: english-us → nobody
Component: English US → General
Product: Tech Evangelism → Firefox
QA Contact: english-us → general
blocking2.0: ? → ---
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
There two overlapping problems here.

1) The site performs bad user agent sniffing. eg: use a nightly from around the time 3.6.x branched (2009-08-xx) and it still only works if the user agent is spoofed to something like:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

2) Even if you spoof the user agent, the site stops working over the following ranges...

m-c:
Last good nightly: 2009-12-01 
First bad nightly: 2009-12-02
Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7f3c1c9fb57&tochange=a5e1b195ecf7

tracemonkey:
Last good nightly: 2009-11-19 
First bad nightly: 2009-11-20
Pushlog: http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=c84622414ed3&tochange=2ca2a236da89

--

Note:
The site works in 3.6.13 ; but does not in the latest nightly or even Chrome 11.0.672.2 dev.

For clarification, the STR:
1) Visit http://www.spirit.com/Reservations.aspx
2) Click the combo box dropdown next to "From:"

Expected:
- Dropdown contains 30+ entries

Actual:
- Dropdown empty
- Multiple entries in error log, eg the one given in comment 0, plus more
The tl;dr version: 

The regression ranges confirm 'use strict' is indeed causing the site to break; but it also seems to be one of the annoying sites that doesn't like Minefield vs Firefox user agents.
This URL is now redirected to 
http://www.spirit.com/ErrorMessage.aspx
In the Book section, I can see dropdown with list of cities. 

Working for me. I suspect the design has changed since the report of this bug. Closing as INVALID.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.