Scrollbar scaled to huge size if image is scaled when using certain themes

RESOLVED DUPLICATE of bug 401213

Status

()

RESOLVED DUPLICATE of bug 401213
8 years ago
4 years ago

People

(Reporter: akruppa, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox34 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.2.13) Gecko/20110103 Fedora/3.6.13-1.fc14 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.2.13) Gecko/20110103 Fedora/3.6.13-1.fc14 Firefox/3.6.13

When scaling up an image with Ctrl-+ and it exceeds the area available in the browser window, scrollbars appear which are scaled up in size as the image is.

Reproducible: Always

Steps to Reproduce:
1. Open an image
2. Adjust browser window size so image can be scaled up enough to exceed available space
3. Keep hitting Ctrl-+ until image exeeds available space

Actual Results:  
Huge scrollbar

Expected Results:  
Scrollbars should stay the usual size.
(Reporter)

Comment 1

8 years ago
Created attachment 515675 [details]
Example of a large scrollbar

Comment 2

8 years ago
 Mozilla/5.0 (X11; Linux i686; rv:2.0b13pre) Gecko/20110228 Firefox/4.0b13pre

I was able to reproduce issue, but I think this is Theme related. Whenever the scrollbars are customized in a theme this issue that you have reported appears.
Component: General → Theme
OS: Linux → All
QA Contact: general → theme
Hardware: x86_64 → All
Summary: Scrollbar scaled to huge size if image is scaled → Scrollbar scaled to huge size if image is scaled when using certain themes

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: firefox-backlog?
status-firefox34: --- → affected
Why was this old bug nominated for the backlog? It was marked as Firefox 34-affected, but I don't think something like this is easily possible. Do you have recent screenshots?
Flags: needinfo?(lhenry)
Flags: needinfo?(florin.mezei)
This is an issue that popped up while testing Themes in Firefox 34 Beta 3 (BuildID=20141023111813) on Windows 8, which is why it was marked as affected for 34. 

Andrei, since you reported seeing this, do you have or could you provide screenshots and maybe some info on what themes were used?
Flags: needinfo?(florin.mezei) → needinfo?(andrei.vaida)
Gavin, like Florin said. It came up in early Beta tests. Sorry, I should have commented along with the nomination. Usually I would do that, but must have just been distracted.
Flags: needinfo?(lhenry)
(In reply to Florin Mezei, QA (:FlorinMezei) from comment #4)
> This is an issue that popped up while testing Themes in Firefox 34 Beta 3
> (BuildID=20141023111813) on Windows 8, which is why it was marked as
> affected for 34. 
> 
> Andrei, since you reported seeing this, do you have or could you provide
> screenshots and maybe some info on what themes were used?

I took another look on Windows 7 64-bit, Windows 8 32-bit, Mac OS X 10.9.5 and Ubuntu 12.04 LTS 32-bit and I can confirm that this issue is currently visible across platforms, using complete themes that also style the scrollbar - here are a few examples:
 * FT DeepDark 11.3.1,
 * NASA Nighty Launch 0.6.20141109,
 * LavaFox V2 2.3.0,
 * Noia Fox 3.0.6.

Since lightweight themes (personas) are not styling the scrollbar, this issue is *not* reproducible with them applied. A few screenshots on this matter: http://i.imgur.com/AlAOj5Q.png | http://i.imgur.com/schwzte.png.
Flags: needinfo?(andrei.vaida)
Bug 401213 gives some context.
Sounds like this is a duplicate of bug 401213.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: firefox-backlog?
Resolution: --- → DUPLICATE
Duplicate of bug: 401213
You need to log in before you can comment on or make changes to this bug.