Closed Bug 637401 Opened 9 years ago Closed 9 years ago

[regression] Console message nodes do not have unique IDs anymore

Categories

(DevTools :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 4.0

People

(Reporter: ddahl, Assigned: ddahl)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

The original landing of the console included a unique ID for each message node logged to the console. Somewhere along the way we lost these ids an each message node is now ID-less

The devtools SDK will include hooks to get and change nodes in almost any way. that will be much more difficult without IDs.
Keywords: regression
I expect this happened around the console restyling patches as they were a near re-write of the message nodes.
Attached patch v 0.1 fixes node ids (obsolete) — Splinter Review
Fixes the node ID issue - this is a dependency of bug 636169
Assignee: nobody → ddahl
Attachment #515704 - Flags: review?(dtownsend)
Blocks: 636169
Attachment #515704 - Flags: approval2.0?
sorry about the fuck up:(
Attachment #515704 - Attachment is obsolete: true
Attachment #515704 - Flags: review?(dtownsend)
Attachment #515704 - Flags: approval2.0?
Attachment #515705 - Flags: review?(dtownsend)
Attachment #515705 - Flags: review?(dtownsend)
Attachment #515705 - Flags: review+
Attachment #515705 - Flags: approval2.0+
Target Milestone: --- → Firefox 4.0
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.