Support for context menu key on Win32 keyboards

VERIFIED DUPLICATE of bug 36665

Status

()

Core
XUL
--
minor
VERIFIED DUPLICATE of bug 36665
18 years ago
10 years ago

People

(Reporter: David Hallowell, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
After the launch of Windows 95 most PC keyboards came with extra keys, one was
to bring up the start menu so doesn't concern Mozilla and the other key had the
same effect as right clicking at the current mouse position.

I never use this feature but as it's an expected feature of windows it should be
included for correctness as there will be some users who expect this functionality.

Expected result:
Press key and context menu appears at current mouse position.

Actual result:
Press key and nothing happens.

Builds tested on:
Mozilla Win32/24Dec2000 plus older builds (this was under Win2000).
Also reproduced on NT 4.0 and Win95

AFAIK Windows is the only OS that supports this. In Linux I have these keys
remapped to do other things.

Comment 1

18 years ago
interesting idea.. reassigning to XPToolkit
Assignee: alecf → pinkerton
Component: Keyboard Navigation → XP Toolkit/Widgets: Menus
QA Contact: sairuh → jrgm
here you go, hyatt. more windoze special key luvin'
Assignee: pinkerton → hyatt

Comment 3

18 years ago
This is bug 36665, assigned to hyatt.

*** This bug has been marked as a duplicate of 36665 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Thanks Dean.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.