IndexedDB: Inserting data with multiple indexes on an autoIncrement object store throws an error

RESOLVED FIXED

Status

()

Core
DOM: IndexedDB
--
major
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Dominique Bosselmann, Assigned: Ben Turner (not reading bugmail, use the needinfo flag!))

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(status2.0 .1-fixed)

Details

(Whiteboard: [fx4-unco-bugday] fixed-on-aurora)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_6; de-de) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

When you create an objectStore with multiple indexes and you try to add data, which has more than one property fitting to indexes, it fails. For better explanation have a look at the testcase.

Reproducible: Always

Steps to Reproduce:
1. Create objectStore with multiple indexes
2. Try to add data, like you can see in the testcase
Actual Results:  
Got an error-event with errorCode = 4

Expected Results:  
Should get a success-event
(Reporter)

Comment 1

6 years ago
Created attachment 516228 [details]
testcase to reproduce the bug
(Reporter)

Updated

6 years ago
Version: unspecified → Trunk

Comment 2

6 years ago
The testcase produces the reported error using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [fx4-unco-bugday]
OS: Mac OS X → All
Hardware: x86 → All
Created attachment 518794 [details] [diff] [review]
Patch, v1

Sigh, this edge case was magically untouched by our tests.
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Attachment #518794 - Flags: review?(sdwilsh)
A inconvenient workaround is to not use autoIncrement object stores for the time being.
Summary: IndexedDB: Inserting data with multiple indexes throws an error → IndexedDB: Inserting data with multiple indexes on an autoIncrement object store throws an error
Comment on attachment 518794 [details] [diff] [review]
Patch, v1

r=sdwilsh
Attachment #518794 - Flags: review?(sdwilsh) → review+
Requesting blocking2.0, but I only want this for 2.0.1, not 2.0.
blocking2.0: --- → ?
blocking2.0: ? → .x+

Updated

6 years ago
blocking2.0: .x+ → Macaw+

Updated

6 years ago
Attachment #518794 - Flags: approval2.0+

Comment 7

6 years ago
Please land on mozilla-central and releases/mozilla-2.0

Comment 8

6 years ago
Also, I want this on mozilla-aurora so that we don't regress from Macaw -> FF 5. This is verbal approval because we don't have the flags set up.
http://hg.mozilla.org/mozilla-central/rev/6bcaec19d09e

http://hg.mozilla.org/releases/mozilla-2.0/rev/96766bc3859b
http://hg.mozilla.org/releases/mozilla-2.0/rev/1bf2d5b7a2d2 (oops!)

http://hg.mozilla.org/mozilla-aurora/rev/8ed51ba58b08
Status: ASSIGNED → RESOLVED
blocking2.0: Macaw+ → ---
Last Resolved: 6 years ago
status2.0: --- → .1-fixed
Resolution: --- → FIXED
Whiteboard: [fx4-unco-bugday] → [fx4-unco-bugday] fixed-on-aurora
Component: DOM → DOM: IndexedDB
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.