Firegestures: Slows down & endless repeats the last command

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
--
major
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Game-R, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Caused by Firegestures?])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

After a while of usage (about 10 hours) the add-on slows down and begins to struggle in identifying gestures. When this happens, Firegestures will get stuck with an issued command in a loop repeating it endlessly. 
For example, when the extension slows down and I draw the gesture to "Close Tab" the Firegestures will repeat it endlessly till all my tabs are lost!
Even scrolling on the tab bar, Firegestures will keep scrolling non-stop and Firefox will become unresponsive. The only way to stop it is to force close Firefox.

Reproducible: Always

Steps to Reproduce:
1.Run Firefox with 10-15 tabs open for about 10 hours or when Firegestures starts to slow down in responsiveness.
2.Draw or run a gesture.
Actual Results:  
Firegestures keeps repeating the last gesture command. Causing Firefox to become unresponsive.

Expected Results:  
Firegesture only executes the gesture command once.
I think this is a Firegestures bug, no a Firefox one. CCing the Firegestures developer.

Updated

7 years ago
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Version: unspecified → 3.6 Branch

Comment 2

6 years ago
Reporter -> Any update?
Whiteboard: [Caused by Firegestures?]
(Reporter)

Comment 3

6 years ago
I've updated to Firefox 4 with a clean new profile and the problem no longer occurs.

Comment 4

6 years ago
Closing bug as WFM - if you are still experiencing this issue or have more information to provide feel free to post back here and we can re-open the bug. You can also get assistance by visiting the Firefox help site -> http://support.mozilla.com/en-US/kb/Ask+a+question
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.