Last Comment Bug 638143 - XUL numberbox shouldn't have their internal html:input inheriting from type
: XUL numberbox shouldn't have their internal html:input inheriting from type
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Mounir Lamouri (:mounir)
:
: Neil Deakin
Mentors:
Depends on:
Blocks: 344616
  Show dependency treegraph
 
Reported: 2011-03-02 10:14 PST by Mounir Lamouri (:mounir)
Modified: 2011-04-13 11:32 PDT (History)
2 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.16 KB, patch)
2011-03-02 10:14 PST, Mounir Lamouri (:mounir)
enndeakin: review+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2011-03-02 10:14:45 PST
Created attachment 516297 [details] [diff] [review]
Patch v1

Because of that, if you create a XUL numberbox, the input inside it will be <input type='number'> which really isn't what we want...

I guess XUL numberbox could use <input type='number'> but that's another bug...
Comment 1 Mounir Lamouri (:mounir) 2011-04-13 11:32:52 PDT
I completely forgot about that patch...

Pushed:
http://hg.mozilla.org/mozilla-central/rev/4624580d88c0

Note You need to log in before you can comment on or make changes to this bug.