Closed Bug 638167 Opened 10 years ago Closed 10 years ago

Session store (undo close tab) should remember scroll position

Categories

(Firefox for Android Graveyard :: General, enhancement, P2)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 604463

People

(Reporter: martijn.martijn, Assigned: mfinkle)

Details

(Whiteboard: [fennec-sessionstore])

Steps to reproduce:
- Go to http://www.nu.nl in a new tab
- Scroll down on that page
- Close the tab
- Tap on 'undo close tab'

Expected result:
- The page should be restored and the scroll positon should be restored too.

Actual result:
- The page is restored, but not the scroll position.
Mark Finkle mentioned on IRC this is probably related to bug 617952.
(In reply to comment #1)
> Mark Finkle mentioned on IRC this is probably related to bug 617952.

Not this bug. This one is purely SessionStore. We need to add saving scroll position when saving state - and then restore it later.

Not for Fennec 4
OS: Windows 7 → All
Hardware: x86 → All
Severity: normal → enhancement
tracking-fennec: --- → ?
Flags: in-testsuite?
Flags: in-litmus?
Priority: -- → P2
Summary: Session store (undo close tab) doesn't remember scroll position → Session store (undo close tab) should remember scroll position
tracking-fennec: ? → 2.0-
Whiteboard: [fennec-sessionstore]
Whiteboard: [fennec-sessionstore] → [fennec-6] [fennec-sessionstore]
Assignee: nobody → mark.finkle
tracking-fennec: - → 6+
Whiteboard: [fennec-6] [fennec-sessionstore] → [fennec-sessionstore]
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604463
tracking-fennec: 6+ → ---
You need to log in before you can comment on or make changes to this bug.