Status

MailNews Core
Composition
--
critical
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Greg Miller, Assigned: Jean-Francois Ducarroz)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
With 2000122604, I attempted to send off a complaint about a spam I've gotten 3
times in the last 24 hours. I did a ctrl+u to view the message source and ctrl+a
to select the contents and headers. It failed to highlight it, but I figured
"hey, maybe it should isn't providing visual cues" so I did a ctrl+c, switched
to the message compose window, clicked in the message text area hit ctrl+v.
Mozilla went down with a resounding thud and talkback id TB23672647X.

Updated

17 years ago
QA Contact: esther → pmock

Comment 1

17 years ago
Reporter do you have the Messages that caused the crash? If so can you attach
them please?

Comment 2

17 years ago
I'm seeing this on 2001010220 on Windows NT.

Only crashes if message being copied is in the inbox, however not if it is in 
another folder.

Using imported profile from 4.7

Comment 3

17 years ago
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
I had this happen when copying from mail and pasting into a news group message.
Here is the dump (I also had two full circles go beck). It happens every time.
message.
Stack trace:
NTDLL! 77fca6cd()
MSVCRT! 7800113d()
NSPR4! 60c875eb()
GKWIDGET! 60adbe21()
GKWIDGET! 60adc219()
GKWIDGET! 60ae1a5b()
EDITOR! 60160539()
EDITOR! 6017651d()
RDF! 607a8f3b()
EDITOR! 6013b626()
XPC3250! 60a2dfe8()
XPC3250! 60a2e843()
JS3250! 60b370cd()
JS3250! 60b3b9ad()
JS3250! 60b3710b()
JS3250! 60b37380()
JS3250! 60b24552()
JSDOM! 60b7f543()
JSDOM! 60b9771d()
GKHTML! 01e6adb7()
GKHTML! 01e6c4ed()
GKHTML! 01e651d4()
GKHTML! 01e65223()
RDF! 60796b2a()
RDF! 607b0177()
RDF! 607b015b()
RDF! 607b015b()
RDF! 607b1900()
JSDOM! 60b7575f()
GKHTML! 01d7cdc9()
GKHTML! 01d958fe()
GKHTML! 01db8476()
GKHTML! 01db8360()
GKVIEW! 603d1406()
GKVIEW! 603d13c7()
GKVIEW! 603d13c7()
GKVIEW! 603da098()
GKVIEW! 603d1dab()
GKWIDGET! 60ad5b3a()
GKWIDGET! 60ad7111()
GKWIDGET! 60ad7320()
GKWIDGET! 60ad5fb9()
USER32! 77e148dc()
USER32! 77e14aa7()
USER32! 77e14bf7()
APPSHELL! 60085dc0()
MOZILLA! 004011b8()
MOZILLA! 00402b48()
KERNEL32! 77e9

disassembly:
77FCA6BC   mov         dword ptr [ebp-58h],eax
77FCA6BF   cmp         edi,eax
77FCA6C1   je          77FCA6D2
77FCA6C3   lea         ecx,[eax-8]
77FCA6C6   mov         dword ptr [ebp-50h],ecx
77FCA6C9   mov         dx,word ptr [ebp-30h]
77FCA6CD   cmp         dx,word ptr [ecx]  ###########died here
77FCA6D0   ja          77FCA6BA
77FCA6D2   mov         dword ptr [ebp-60h],eax
77FCA6D5   mov         edx,dword ptr [eax+4]
77FCA6D8   mov         dword ptr [ebp-5Ch],edx
77FCA6DB   lea         ecx,[esi+8]
77FCA6DE   mov         dword ptr [ecx],eax
77FCA6E0   mov         dword ptr [esi+0Ch],edx
77FCA6E3   mov         dword ptr [edx],ecx
77FCA6E5   mov         dword ptr [eax+4],ecx
77FCA6E8   mov         ecx,dword ptr [ebp-30h]
77FCA6EB   mov         eax,dword ptr [ebp-34h]
77FCA6EE   add         dword ptr [eax+28h],ecx
77FCA6F1   jmp         77FCA67A
77FCA6F3   cmp         byte ptr [ebp-2Ch],0
77FCA6F7   je          77FCA707
77FCA6F9   mov         eax,dword ptr [ebp-34h]
77FCA6FC   push        dword ptr [eax+578h]

Comment 5

17 years ago
I had a problem like this (maybe the same thing, I think) shortly before the
2001021508 release (See http://bugzilla.mozilla.org/show_bug.cgi?id=68931), but
nobody, including me, was able to duplicate it in the newer releases stable. 
Might it have been fixed since the 2000122604 build?  Is anyone still having
this problem with releases more current than 2000122604?

Updated

17 years ago
Severity: major → critical
Keywords: crash

Comment 6

17 years ago
It has worked for me lately. 2001060903 works!

Updated

17 years ago
Keywords: nsenterprise

Comment 7

17 years ago
Marking worksforme per the previous comment.  Please reopen if it's still
reproducable with a new nightly.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
Win32 (2001-07-10-05-0.9.2)
This bug is gone.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.