Newlines in title tooltip is shown as two vertical lines (||)

VERIFIED DUPLICATE of bug 47078

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 47078
18 years ago
17 years ago

People

(Reporter: Henrik Gemal, Assigned: harishd)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
If you have:
<a href="t" title="Henrik Gemal &lt;gemal.dk@fep2.x.dk&gt;
Henrik Gemal &lt;gemal.dk@fep2.x.dk&gt;
Henrik Gemal &lt;gemal.dk@fep2.x.dk&gt;">Henrik Gemal &lt;gemal.dk@fep2.x.dk&gt;</a>

that's a title tag that includes a newline the newline char is show as || in the
tooltip when the cursor is over the link.

Expected:
Newlines in title tags should just be ignored.

Build Gecko/20001226
(Reporter)

Comment 1

18 years ago
Created attachment 21338 [details]
testcase with newlines in title tag
(Reporter)

Comment 2

18 years ago
Correction:
Newlines shouldn't be ignored.
The title should just be shown correct with the newlines.
Will attach screenshot of Mozilla and IE handling the attached testcase.
Summary: Newlines in title tooltip is show a two vertical lines (||) → Newlines in title tooltip is shown as two vertical lines (||)
(Reporter)

Comment 3

18 years ago
Created attachment 21339 [details]
screenshot of ie and mozilla with newlines in title

Comment 4

18 years ago
Happens with the "MIT" link at the bottom of http://www.w3.org/DOM/ as well.

cc'ing Hixie to make sure we're right about what the the correct behavior is.
Correct behaviour is to treat newlines as whitespace (and trim leading and 
trailing whitespace) per HTML4 and SGML. I don't know what we should do in
XML. This is a parser-level requirement per the spec. Check Bugzilla's INVALID,
WONTFIX and FIXED bugs with the words "newline" and "attribute" in the 
description fields for bugs similar to this one where this has been discussed 
to death.
But what should we do for &#013; ?  (What do we do now?)  In a DOM where we want
to preserve all whitespace for editing, etc. (perhaps this is contrary to SGML,
though, but...), how should we behave?  (How should we handle 'content: attr(X);
white-space: pre'?)

Comment 7

18 years ago
> But what should we do for &#013; ?

Exactly the same thing we do for ordinary CRs/LFs. There are *no* difference in:

<CR>
&#x000d;
&#013;

They're *exactly* the same characters (they're canonically equivalent).

See also <URL: http://www.w3.org/TR/charmod/ >
*** Bug 72670 has been marked as a duplicate of this bug. ***
*** Bug 72984 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
Reassigning to harishd.
Assignee: clayton → harishd
(Assignee)

Comment 11

18 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration -----
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 12

17 years ago
I think this is a duplicate of bug 59743.

*** This bug has been marked as a duplicate of 47078 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 14

17 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.