Last Comment Bug 638670 - Add 602plugin.so to list of Xt plugins that are run in process.
: Add 602plugin.so to list of Xt plugins that are run in process.
Status: RESOLVED FIXED
[fx4-rc-ridealong]
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla5
Assigned To: Karl Tomlinson (:karlt)
:
:
Mentors:
Depends on:
Blocks: 544088
  Show dependency treegraph
 
Reported: 2011-03-03 19:45 PST by Karl Tomlinson (:karlt)
Modified: 2011-04-11 15:33 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
Macaw+
.1-fixed


Attachments
patch (846 bytes, patch)
2011-03-03 19:52 PST, Karl Tomlinson (:karlt)
benjamin: review+
dveditz: approval2.0+
Details | Diff | Splinter Review

Description Karl Tomlinson (:karlt) 2011-03-03 19:45:25 PST
I was contacted re the plugin at http://www.602.cz/lin/download_form_filler
It is an Xt plugin using XtWindowToWidget and XtAddEventHandler.
Apparently they have government clients.
I haven't tried the plugin.  It looks like it starts a wine process.  I don't know much more than that.

Until bug 544088 is fixed, Xt plugins will fail when run out of process, so we should add know Xt plugins to the list.
Comment 1 Karl Tomlinson (:karlt) 2011-03-03 19:52:07 PST
Created attachment 516789 [details] [diff] [review]
patch
Comment 2 Karl Tomlinson (:karlt) 2011-03-06 18:49:43 PST
Requesting ".x+".

This is a pref-only change adding another plugin to an existing oop-blacklist for Xt plugins such as this plugin.  The plugin authors confirm that their plugin works fine with this preference set.  I expect the proportion of our users with this plugin is small, but the risk to those without in zero.
Comment 3 Robert Sayre 2011-03-07 12:28:54 PST
Comment on attachment 516789 [details] [diff] [review]
patch

Cancelling approval request. Please re-request approval for the release after Firefox 4, when the patch has had some time on the trunk. In the meantime, users have a workaround via the pref in the patch.
Comment 6 Daniel Veditz [:dveditz] 2011-03-31 11:51:06 PDT
Comment on attachment 516789 [details] [diff] [review]
patch

Approved for mozilla2.0 repository, a=dveditz for release-drivers
Comment 7 christian 2011-04-11 15:33:50 PDT
Transplanted from mozilla-central onto releases/mozilla2.0:

    http://hg.mozilla.org/releases/mozilla-2.0/rev/471272f0e72a

Note You need to log in before you can comment on or make changes to this bug.