Search does not show a compatible new version of a globally installed incompatible add-on

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
RESOLVED WONTFIX
7 years ago
6 months ago

People

(Reporter: Aleksej, Unassigned)

Tracking

({uiwanted})

Trunk
uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addons-testday][rc4])

(Reporter)

Description

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

* I have an old version of NoScript installed globally in my system.
** That version is not compatible with Firefox 4, and thus disabled.
* AMO has a newer version which is compatible.
** Add-on Manager's remote search doesn’t show that version because of the installed one, saying something like “No compatible add-ons found”.

Problem: cannot use Add-on Manager to find out that a compatible version is available for profile-wide install.
Whiteboard: [addons-testday] → [addons-testday][rc4]
Can can't generally not use search to find out if new versions of an addon are available. Therefore you will have to perform an update check. The above steps will also not work with an extension installed into the profile.
(Reporter)

Comment 2

7 years ago
Because the add-on is installed globally, I didn't install it into the profile. It is disabled, so I have no idea that it is installed.

Maybe the search could show that there are hits among the installed add-ons.
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> Because the add-on is installed globally, I didn't install it into the profile.

Sorry, I mean: it is installed although I didn't install it.
Indeed, this is intentional. Perhaps showing the number of results in the "My Add-ons" and "Available Add-ons" tab labels could help with this sort of problem.
Keywords: uiwanted
OS: Linux → All
Hardware: x86 → All

Comment 5

7 years ago
Please make globally installed Add-ons updatable!
They got automatically updated via update from 4.0.1 to 5.0, but that's all.
Now I have few incompatible Add-ons. If they would become compatible some day, I can't have them updated, if the are installed globally. That more than a pity.

Updated

7 years ago
Depends on: 667987
Even if we were to make global add-on updatable it wouldn't affect this bug, they are quite different issues.
No longer depends on: 667987
This bug is about the search UI that was removed in bug 1263313.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.