Closed Bug 638994 Opened 10 years ago Closed 10 years ago

"Options", "Disable" & "Remove" Buttons for Addons In Seamonkey Add-ons Manager Are Either Missing Or Not Shown Completely Within the Window When Using Seamonkey "Modern" Theme

Categories

(SeaMonkey :: Themes, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 568052

People

(Reporter: erpman1, Unassigned)

Details

(Keywords: modern)

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110304 Firefox/4.0b13pre SeaMonkey/2.1b3pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110304 Firefox/4.0b13pre SeaMonkey/2.1b3pre

See screenshot.  Proof is well said in the picture.

the Options, Disable and Remove buttons in the Add-ons Manager for most of the addons installed are missing.



Reproducible: Always

Steps to Reproduce:
1. Run Seamonkey 2.1b2 or any 2.1b3pre build
2. Click Tools, Add-on Manager
3. Resize Seamonkey browser window and make it smaller or use a lower screen resolution such as 800x600.
Actual Results:  
A list of add-ons are displayed without the "Options", "Disable" and "Remove" buttons and no vertical scroll bar is displayed to show remaining add-ons.

Expected Results:  
A list of add-ons should be displayed WITH the the "Options", "Disable" and "Remove" buttons and a vertical scroll bar should be displayed so users can click on it to show the remaining add-ons if there are a lot of add-ons installed.
Attached image screenshot
almost forgot to mention, this seems to affect Seamonkey 2.1b2 and 2.1b3pre builds when using the Seamonkey Modern theme.  when I switch to the Seamonkey Default "Classic" theme, the problem described above does not occur.
Version: unspecified → Trunk
Mmm, I'm using the modern theme as well and 2.1b2 and 2.1b3 had the Option / diable / Remove buttons.
Did you try from a fresh profile ? One of the add-ons may botch up the page...
The problem is that there is no themeing for the about:addons in our Modern theme.
Status: UNCONFIRMED → NEW
Component: UI Design → Themes
Ever confirmed: true
Keywords: modern
OS: Windows XP → All
QA Contact: ui-design → themes
Hardware: x86 → All
(In reply to comment #3)
> Mmm, I'm using the modern theme as well and 2.1b2 and 2.1b3 had the Option /
> diable / Remove buttons.
> Did you try from a fresh profile ? One of the add-ons may botch up the page...

@Dominique Fillon: Please read step 3 of the "Steps to Reproduce" section VERY CAREFULLY!  You're probably not seeing the problem because you're most likely using a high video resolution (1024x768) or higher.  If you are using a high screen resolution, change your video settings to a resolution of 800x600 or less, then run Seamonkey 2.1b2 or 2.1b3pre with SM modern theme and open addons manager.

AND I AM using a fresh new profile and I'm still seeing the problem.
I'm using an old 15 inch HP Pavilion monitor running at screen resolution of 800 by 600.

I'm adding another screenshot of the problem but under a win2000 machine.
Attached image screenshot2-win2k
Attachment #517260 - Attachment mime type: image/png → image/jpeg
Attached image screenshot3-xp
new screenshot of the problem.  this time at video resolution of 1024x768 on my WinXP computer.  The Options button gets displayed for one addon but the Disable buttons for all of them are either not being shown or are covered up.

guys, I have proof.  I have evidence to back my claim.  don't know if these problems occur on Mac & Linux OSes but they do happen under Windows OSes.
Summary: Missing "Options", "Disable" & "Remove" Buttons for Addons In Seamonkey Add-ons Manager → "Options", "Disable" & "Remove" Buttons for Addons In Seamonkey Add-ons Manager Are Either Missing Or Not Shown Completely Within the Window
Attached image screenshot4-vista
here's another screenshot I took when installing and running a Seamonkey 2.1b3pre nightly build on a Windows Vista computer and using Seamonkey "Modern" theme and using a screen resolution of 1280 by 800.

notice closely in this screenshot how the "Disable" buttons on each of the add-ons installed are cut off and are not 'repositioned' or 'realigned' to stay within the addons manager window.

the problem is similar to bug 595856.  check out the screenshots of bug 595856.
Summary: "Options", "Disable" & "Remove" Buttons for Addons In Seamonkey Add-ons Manager Are Either Missing Or Not Shown Completely Within the Window → "Options", "Disable" & "Remove" Buttons for Addons In Seamonkey Add-ons Manager Are Either Missing Or Not Shown Completely Within the Window When Using Seamonkey "Modern" Theme
Clearer steps to reproduce the problem-

1. install and run Seamonkey 2.1 beta 2 or any Seamonkey 2.1b3pre nightly build
2. on the menu bar, click on View, Apply Theme and select Seamonkey Modern, then restart Seamonkey
3. on the menu bar, click on Tools & select Add-On Manager
4. if using high video resolutions like 1280x800 or 1024x768, resize the Seamonkey browser window and make the window smaller [OR use smaller video resolutions such as 800x600 or 640x480] and see if the "Options", "Disable" and/or "Remove" buttons stay within the window; if they don't or if the buttons get cut off, the problem occurs

the bug is somewhat annoying but the problem is real.
(In reply to comment #9)
> the bug is somewhat annoying but the problem is real.

No-one doubts this. The bug is confirmed and the cause of the problem is decribed in comment #4.
(In reply to comment #10)

> No-one doubts this. The bug is confirmed and the cause of the problem is
> decribed in comment #4.

indeed Stefan.  now that the problem has been recognized by others, will there be someone on the Seamonkey team assigned to fix the problem?

I know this problem can NOT be ignored and MUST be fixed before Seamonkey 2.1 reaches final release.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 568052
all right.  i guess i have to wait for bug 568052 to get fixed then.  hopefully that one will get fixed before Seamonkey 2.1 gets finalized.
problem has been fixed starting with the 5/7/2011 SM2.1pre nightly build I've just downloaded and installed on my XP computer, yay!
You need to log in before you can comment on or make changes to this bug.