Closed Bug 6391 Opened 21 years ago Closed 20 years ago

[FEATURE] Windows Splash screen

Categories

(SeaMonkey :: UI Design, defect, P1)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: elig, Assigned: law)

References

Details

(Whiteboard: [PDT+] Feb10)

Attachments

(4 files)

* TITLE/SUMMARY
Seamonkey needs a splash screen, so that users know it didn't crash on launch ;)

* STEPS TO REPRODUCE
0) Launch Apprunner
1) Wait 30 seconds.

* RESULT
 - What happened

If you're running on a system equivalent or slower to mine (Mac OS 233 Mhz 604e),
you still haven't seen any feedback that Seamonkey is launching. In fact, I was
even thought it crashed on launch on a few times and was almost ready to
restart...

I assume this is a planned item, but it's not listed under any of the milestone
schedules on http://warp.mcom.com/client/seamonkey/.

 - What was expected

Platform-native splash screen that appears within 2-3 seconds of launching
application, to provide immediate feedback that the application didn't just crash
on launch.
QA Contact: 3853 → 1698
Priority: P3 → P1
Target Milestone: M9
Of course, ideally, the app should just be optimised to the point of not having
any substantial startup time, and thus the splash screen would not be required.

This is not just an "oh yeah, ideally, but this is the real world" type
statement. Many things that are loaded at the start of AppRunner need not
actually be started then at all. For example, the mail components are currently
loaded (well, bootstrapped, anyway) at startup, and yet it is quite likely
that I won't even go anywhere near the mail parts of the browser.
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.
Severity: enhancement → normal
Component: other → XPApps
Summary: Need splash screen, so users know it didn't just crash on launch → [FEATURE] Splash screen
Target Milestone: M9 → M10
What's up with this? Do we have a plan for the startup screen?
Target Milestone: M10 → M11
Whiteboard: Need to find an owner for this
Blocks: 10575
Assignee: don → davidm
Whiteboard: Need to find an owner for this → Can this be done XP?
Target Milestone: M11 → M10
David, find out whether it's possible to implement this in a truly XP way.  If
not, let me know and help you find victims for the Windows and Linux
implementations.
I think the splash screen is inapproprite for a mozilla build. Anyone object to
using the mozilla classic splash screen?
what does the mozilla classic splash screen look like?
Whiteboard: Can this be done XP?
Since this can't be done in an XP way, do we need separate bugs for each
platform?  That way we can decide not to do this on Linux for the beta. :-)
Blocks: 12659
Summary: [FEATURE] Splash screen → [BETA][FEATURE] Splash screen
Assignee: davidm → don
I checked in an initial Mac Spash Screen implementation. I don't have the tools
required to convert Gif's to Picts so I use the old mozilla screen. Should
probably be enhanced to provide progress messages ( so they don't think the
program has crashed) but that can be a RFE if we can get a reasonable startup
time. Reassigning to Don to find a victim to do a windows version.
Assignee: don → jevering
No longer blocks: 12659
OS: All → Windows NT
Hardware: All → PC
Summary: [BETA][FEATURE] Splash screen → [FEATURE] Splash screen
Target Milestone: M10 → M11
Jim, this is no longer a beta requirement, but since you volunteered can you do
the Windows implementation?
Blocks: 13110
Summary: [FEATURE] Splash screen → [BETA][FEATURE] Splash screen
Well, it's no longer a mozilla.org beta requirement ...
Target Milestone: M11 → M13
beta=m13
No longer blocks: 10575
Assignee: jevering → law
No longer blocks: 13110
Summary: [BETA][FEATURE] Splash screen → [FEATURE] Splash screen
Target Milestone: M13 → M14
Bill ...
Summary: [FEATURE] Splash screen → [FEATURE] Windows Splash screen
Re-summarized.
Status: NEW → ASSIGNED
Marking beta1 (seems like kind of a biggie, and I've got it implemented; 
awaiting code review of Windows portion of it).
Keywords: beta1
PDT+
Whiteboard: [PDT+]
I have a few of screens at http://www.mozillazine.org/splash/.  2 and three are 
the best I think.  I will work on an icon for windows and add it there.  Take a 
look.  
Component: XPApps → XP Utilities
Why is this PDT+ for beta1?!?!
Why is it that the splash screen is compiled?  Why is it not a gif that is 
editable?  Or at least changable?  I wanted to see what my images looked like, 
but there is no way, as far as I can see.
Remaining task is to hack the Netscape build to provide branded splash screen 
bitmap and program icon.  I'm holding those changes in my tree and plan to check 
it in tomorrow.

P.S. I still need a program icon.  You won't like the one I'm using, I promise.
Whiteboard: [PDT+] → [PDT+] Feb10
Blocks: 25150
Changes checked into commercial build.  Graphics will be updated shortly so 
don't complain about the ugly ones for a while.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I confirm that this morning's build has an ugly, dithered-gray splash screen with 
text that wouldn't be appropriate for a Netscape-banded beta release.

Thus, marking as verified.

---

Bill, might you know off the top of your head if there's a bug for tracking the 
insertion of the actual Beta splash screen bitmap? Thanks!
Status: RESOLVED → VERIFIED
I checked in the latest and greatest version of the bitmap I've received.  It 
should look better tomorrow.
Component: XP Utilities → XP Apps: GUI Features
Product: Core → Mozilla Application Suite
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.