If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Table rendering is very slow

VERIFIED DUPLICATE of bug 60494

Status

()

Core
Layout: Tables
VERIFIED DUPLICATE of bug 60494
17 years ago
17 years ago

People

(Reporter: Eric Vaandering (no email), Assigned: karnaze (gone))

Tracking

({perf})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Rendering of some long-ish tables takes a very long time. For instance, I rent
movies via www.netflix.com. I usually have about 170 movies in my queue, so to
render the table with 170 rows takes at least 10 seconds.

I'll attach a sample from tvguide.com where I've doubled the number of entries.
This table takes about 10 seconds to come up (no preview) under mozilla and
about 2 seconds under Netscape 4.76.

Somewhere I thought I remembered seeing something about tables and bgcolor (both
examples I'm giving use it) but I can't find anything now.
(Reporter)

Comment 1

17 years ago
Created attachment 21406 [details]
Doubled table from tvguide.com which shows slow rendering

Comment 2

17 years ago
This took a -long- time in my 122821 build. About 15 secs to render the page,
and then approximately 10 further secs before mozilla would respond to scrolling
or hovering over the Stop button.

My machine: Debian Woody K6-2 300Mhz 256Mb RAM. I suspect this could be a layout
or parser issue, and could well be a dup. Adding perf keyword and leaving
unconfirmed for further dup triage. This needs someone with more knowledge of
existing bugs to mark confirm or duplicate.
Keywords: perf

Comment 3

17 years ago
as the validator.w3.org shows the page has a bunch of unclosed <font> tags. And
this makes mozilla mad.

*** This bug has been marked as a duplicate of 60494 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified dupe of bug 60494: "Mozilla is extremly slow rendering this page lots
of <font> tags"
The problem is very similar, there is a table and the font tag.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.