Lotus Domino Web Access fails to recognize Firefox for Android UA

RESOLVED INVALID

Status

RESOLVED INVALID
8 years ago
2 years ago

People

(Reporter: jswisher, Unassigned)

Tracking

unspecified
Other
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: 

Reporting this for a friend, so I don't have the build ID, but it was mobile Beta 5.

When using Lotus Domino Web Access (webmail UI for Lotus Notes) on a Motorola Xoom with Android 3.0, the webmail list view displays, but messages cannot be opened. You can select messages, but neither double-tapping nor tap-and-hold  works to open them. Clicking the Reply button *does* create a reply for the selected message.

Also, the thumbnail for the tab does not show the webmail UI, only the blank screen with a status message that appears before the webmail UI appears. That makes me think that Domino is painting the contents of the webmail UI in a way that Fennec doesn't see, and so the taps are not passed through properly.

Reproducible: Always

Steps to Reproduce:
1. Log in to a Domino Web Access account (maybe someone at IBM can help with this?)
2. Select an email message in the list.
3. Try to open the message using either double-tap or tap-and-hold.
Actual Results:  
Double-tap results in the view being unzoomed if it was zoomed. Tap-and-hold results in a "blank" screen with the checkerboard pattern, but this is never filled with content.

Expected Results:  
Display the contents of the selected message, either in a new tab, or replacing the list view.
This seems like a problem with the Lotus page. A mobile-optimized page should not require double-click but rather open the message with a single click or tap.
Two potential workarounds:
(1) Install https://addons.mozilla.org/en-US/mobile/addon/touching-is-good/ and then use the Android Menu in the Browser to switch to mouse mode - that will allow you to do a double-tap instead of zooming
(2) Install https://addons.mozilla.org/en-US/mobile/addon/phony/ and then set the User Agent under Browser -> Preferences to Android to force Lotus to show the mobile page, instead of the desktop page
Let me know how this works.
-> moving to tech evangelism for IBM / Lotus can recognize our user agent
Assignee: nobody → english-us
Component: General → English US
Product: Fennec → Tech Evangelism
QA Contact: general → english-us
Target Milestone: --- → Mar
Version: Trunk → unspecified

Comment 3

8 years ago
Tweaking summary to what I *think* it should be, but someone else should feel free to re-summarize if I messed up.
Summary: Unable to open messages Lotus Domino Web Access → Lotus Domino Web Access fails to recognize Fennec's UA

Updated

4 years ago
Assignee: english-us → nobody
Component: English US → Mobile
Summary: Lotus Domino Web Access fails to recognize Fennec's UA → Lotus Domino Web Access fails to recognize Firefox for Android UA
Janet, can you ask your friend if this is still a problem? We need access to such a system to try to debug it if it is..
Flags: needinfo?(jswisher)
(Reporter)

Comment 5

4 years ago
Asking ... will let you know the outcome.
Flags: needinfo?(jswisher)
(Reporter)

Comment 6

4 years ago
My friend no longer has an Android device, so he is not able to reproduce it. I will see him in December, so I will try to remember to get him to try it on one of mine.

Comment 7

2 years ago
I think we should close this. For two reasons, 

* very hard to have a meaningful diagnosis without access to the actual product
* outreach which will likely fail if we can't pinpoint the issue.

The best path of action would be for the customer to contact Lotus/Notes directly 

If anyone has a possibility to diagnoses that on the product itself, that would be great. We could reopen.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.