Last Comment Bug 639554 - "make install" doesn't install the full SDK
: "make install" doesn't install the full SDK
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- minor (vote)
: mozilla7
Assigned To: Chris Coulson
:
Mentors:
: 679001 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-07 11:05 PST by Chris Coulson
Modified: 2011-08-23 10:18 PDT (History)
4 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Install sdk/bin with make install (942 bytes, patch)
2011-03-07 11:05 PST, Chris Coulson
benjamin: review+
Details | Diff | Review

Description Chris Coulson 2011-03-07 11:05:13 PST
Created attachment 517465 [details] [diff] [review]
Install sdk/bin with make install

I downloaded a SDK from ftp.mozilla.org, and noticed that it contains the following files which don't exist in the SDK created with "make install":

sdk/bin/nspr-config
sdk/bin/xpidl
sdk/bin/xpt_dump
sdk/bin/xpt_link

The attached patch fixes this
Comment 1 Mike Hommey [:glandium] 2011-05-25 23:51:28 PDT
http://hg.mozilla.org/projects/cedar/rev/99672871e930
Comment 2 Mounir Lamouri (:mounir) 2011-05-27 01:05:11 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/99672871e930
Comment 3 Mike Hommey [:glandium] 2011-08-15 10:18:34 PDT
*** Bug 679001 has been marked as a duplicate of this bug. ***
Comment 4 Ionut Biru 2011-08-23 10:18:28 PDT
even with that fix it still has problems.
1) is not installed with execute flag and projects that relies on it fail with

make: execvp: /usr/lib/xulrunner-devel-6.0/sdk/bin/xpt.py: Permission denied

2) it has a hardcoded shebang and doesn't respect PYTHON detected by ./configure

Note You need to log in before you can comment on or make changes to this bug.