Consider caching the return value of mozResponseArrayBuffer

RESOLVED DUPLICATE of bug 658683

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 658683
7 years ago
7 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

It's a matter of time before someone writes silly code that gets this property over and over...

For .responseText we use a shareable string buffer, so once we compute it once every get is just an addref.

For .mozResponseArrayBuffer, could we cache the actual JSObject?  If not, could we cache the backing store?

Note that we have to be careful here because unlike strings typed arrays are _mutable_.  So if we did cache we'd need to somehow invalidate the cache on writes from JS too... or something.

Maybe this isn't very doable.
.mozResponseArrayBuffer has been changed to .response with .responseType="arraybuffer", and property value caching has been implemented in bug 658683.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 658683
You need to log in before you can comment on or make changes to this bug.