Closed Bug 639698 Opened 11 years ago Closed 11 years ago

Block NVIDIA drivers >= 7.0.0.0 on Windows XP

Categories

(Toolkit :: Blocklist Policy Requests, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: joe, Assigned: fligtar)

References

Details

(Whiteboard: [server side][can ship RC without][noncode])

As an alternative to landing bug 638936 on m-c, we're going to blacklist NVIDIA drivers with versions we don't recognize. In this case, that's >= 7.0.0.0. 

Here's some SQL:

INSERT INTO `blgfxdrivers` (NULL, NULL, 'WINNT 5.1', '0x10de', '',
'DIRECT3D_9_LAYERS', 'BLOCKED_DRIVER_VERSION', '7.0.0.0', 'GREATER_THAN_OR_EQUAL', NOW(), NOW())

I'm not sure how the AMO service is going to react to an empty device ID, so I'm very interested in seeing the XML output by staging!
blocking2.0: --- → ?
Depends on: 639723
Rationale for blocking? Do we think it's very common? I think we should definitely *do* it, just wondering if we should be holding the release for this.

Speculatively marking blocking+ for now, but would like to get input on that.
blocking2.0: ? → final+
Whiteboard: [server side][needs testing][can ship RC without]
Whiteboard: [server side][needs testing][can ship RC without] → [server side][needs testing][can ship RC without][noncode]
As explained in bug 638936, 1.8% of the current beta/nightly users have this bug, i.e. have an old driver version that gets mistakenly whitelisted.

1.8% is already a lot and we can expect this proportion to grow higher among stable users.
I meant 'crash reports', not 'users'. But that should not make a huge difference.
I think the issue you are running into here is caused by manufacturers who produce their own customized version of NVIDIA drivers.  IT appears that perhaps the first 2 components are kind of an HP or Dell etc version number it is just the last 2 components that tell you the NVIDIA version.

The solution in bug 638936, although perhaps more risky, is probably more correct and is less likely to create backlash of Mozilla seeming to prefer one laptop hardware vendor over an other.
This is on staging:

  <gfxBlacklistEntry>
    <os>WINNT 5.1</os>
    <vendor>0x10de</vendor>
    <feature>DIRECT3D_9_LAYERS</feature>
    <featureStatus>BLOCKED_DRIVER_VERSION</featureStatus>
    <driverVersion>7.0.0.0</driverVersion>
    <driverVersionComparator>GREATER_THAN_OR_EQUAL</driverVersionComparator>
  </gfxBlacklistEntry>
I've tested this on staging (using the instructions I just wrote in https://wiki.mozilla.org/Blocklisting/Testing ) and everything looks good. We don't block people running the correct version of the driver and we don't block people on other OSes.

This can be pushed live.
Assignee: nobody → fligtar
Whiteboard: [server side][needs testing][can ship RC without][noncode] → [server side][can ship RC without][noncode]
Depends on: 641604
This is blocked in production.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.