Last Comment Bug 640175 - Search criteria typed in URL Bar doesn't match with the history/Awesomelist content
: Search criteria typed in URL Bar doesn't match with the history/Awesomelist c...
Status: VERIFIED FIXED
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 8
Assigned To: Lucas Rocha (:lucasr)
:
Mentors:
: 642923 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-09 07:32 PST by Cristian Nicolae (:xti)
Modified: 2011-10-07 04:02 PDT (History)
9 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Special case the "www." prefix in AutoCompleteCache (906 bytes, patch)
2011-07-29 10:45 PDT, Lucas Rocha (:lucasr)
mark.finkle: review+
Details | Diff | Review
Updated patch with hg user info and commit message (1.50 KB, patch)
2011-08-01 11:37 PDT, Lucas Rocha (:lucasr)
mark.finkle: review+
Details | Diff | Review

Description Cristian Nicolae (:xti) 2011-03-09 07:32:56 PST
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b13pre) Gecko/20110309 Firefox/4.0b13pre Fennec /4.0b6pre

The Awesomelist doesn't return a correct result for the typed search criteria.

Reproducible: Always

Steps to Reproduce:
Try to reproduce the steps on a fresh profile:
1. Open Fennec App
2. Browse to www.mozilla.com
3. Wait until the page is completely loaded
4. Open a new tab
5. On URL Bar type www.m
Actual Results:  
The Awesomelist is populated only with the suggestion of the preinstalled search engines: << Search for "www.m" >>. The websites from history which match the search criteria are missing.

Expected Results:  
The Awesomelist is populated with all the sites who beggin with "www.m", in a descend order sort by most access time.

Build id : Mozilla/5.0 (Maemo;Linux armv7l;rv:2.0b13pre)Gecko/20110309
Firefox/4.0b13pre Fennec /4.0b6pre
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1
Comment 1 Cristian Nicolae (:xti) 2011-03-09 07:47:45 PST
For more details, please see the following video: http://www.youtube.com/watch?v=aeZMdl9o85k
Comment 2 Kevin Brosnan [:kbrosnan] 2011-03-14 10:58:57 PDT
I can reproduce this on the same phone - Mozilla/5.0 (Android; Linux armv7l; rv:2.0b13pre) Gecko/20110314 Firefox/4.0b13pre Fennec/4.0b6pre ID:20110314043938
Comment 3 Cristian Nicolae (:xti) 2011-03-16 06:49:12 PDT
This issue is still reproducing on:
Build id : Mozilla/5.0 (Maemo;Linux armv7l;rv:2.0b13pre)Gecko/20110316
Firefox/4.0b13pre Fennec /4.0b6pre
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1

I noticed that if on step 5 I type "www.mo" and then I delete "o", the Awesomelist will be populated as expected.
Comment 4 Cristian Nicolae (:xti) 2011-05-24 02:24:01 PDT
TC https://litmus.mozilla.org/show_test.cgi?id=12170 fails due to this bug.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-07-28 09:40:08 PDT
Is this still happening?
Comment 6 Cristian Nicolae (:xti) 2011-07-28 10:33:25 PDT
(In reply to comment #5)
> Is this still happening?

Yes, it's still reproducing on the latest Nightly build.

--
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:8.0a1)Gecko/20110728
Firefox/8.0a1 Fennec/8.0a1
Device: HTC Desire Z
OS: Android 2.2.1
Comment 7 Lucas Rocha (:lucasr) 2011-07-28 13:37:40 PDT
Interestingly, it works fine if you only type 'm' (with no 'www.' prefix). Fixing.
Comment 8 Lucas Rocha (:lucasr) 2011-07-29 10:45:07 PDT
Created attachment 549416 [details] [diff] [review]
Special case the "www." prefix in AutoCompleteCache

This bug is caused by a change in platform where the "www." prefix is being ignore on autocomplete searches (see bug 461483). This patch special-cases the  "www." prefix in the search optimization done as part of bug 609603.
Comment 9 Lucas Rocha (:lucasr) 2011-08-01 11:37:14 PDT
Created attachment 549865 [details] [diff] [review]
Updated patch with hg user info and commit message
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2011-08-09 06:59:02 PDT
pushed with a quick string fix for bug 676293
http://hg.mozilla.org/mozilla-central/rev/fc0c60debaae
Comment 11 Aaron Train [:aaronmt] 2011-08-10 06:05:07 PDT
Verified Fixed
Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110810 Firefox/8.0a1 Fennec/8.0a1
Comment 12 Lucas Rocha (:lucasr) 2011-10-07 04:02:49 PDT
*** Bug 642923 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.