Last Comment Bug 640307 - notifications opened in one tab leave a blank area at the bottom of webpages loaded onto another tab
: notifications opened in one tab leave a blank area at the bottom of webpages ...
Status: VERIFIED FIXED
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 7
Assigned To: Wesley Johnston (:wesj)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-09 13:08 PST by Aakash Desai [:aakashd]
Modified: 2011-07-14 21:37 PDT (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (1.42 KB, patch)
2011-03-09 14:42 PST, Wesley Johnston (:wesj)
mark.finkle: review+
Details | Diff | Splinter Review

Description Aakash Desai [:aakashd] 2011-03-09 13:08:53 PST
Build Id:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b13pre) Gecko/20110309 Firefox/4.0b13pre Fennec/4.0b6pre

Steps to Reproduce:
1. Go to touch.facebook.com
2. Open a new tab and go to maps.google.com
3. Go back to the first tab with facebook loaded
4. Pan down to the bottom of the page

Actual Results:
There will be a grey/empty/blank area at the bottom of the page until a user closes the offline storage/geolocation notifications from the other tab

Expected Results:
There shouldn't be a grey/empty/blank area on one tab due to notifications popped-down on another tab.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-03-09 13:17:40 PST
should be fixed by bug 639985, if I am guessing correctly
Comment 2 Wesley Johnston (:wesj) 2011-03-09 13:27:17 PST
I don't think these are the same. All our notification boxes are in a deck:

<deck>
  <notificationbox>

  <notifictationbox/>
</deck>

And each box contains a set nois width-width and window-height wide. When the notification box shows, one of the grows to window-height + notification-height.
Comment 3 Wesley Johnston (:wesj) 2011-03-09 14:42:15 PST
Created attachment 518183 [details] [diff] [review]
Patch

Sorry. Keyboard failure on my end. One simple workaround for fixing this is actually stack the notification box and the browser. Of course, that makes it so that you can't pan the top row of content out from behind the notification box either (but our notifications are so big that they are hard to ignore anyway).

Sees a bit scary to take so late. Surprising none of us saw this until now anyway.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-04-08 02:05:21 PDT
I'd like to talk to madhava and brian about dropping the blue notification boxes and switching to door hanger arrow boxes. That could make this better too I think.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-19 21:02:55 PDT
Comment on attachment 518183 [details] [diff] [review]
Patch

Let's try this for now. I still want to remove the notification boxes altogther and use door hangers, but not for Fx6.
Comment 6 Wesley Johnston (:wesj) 2011-05-31 13:38:48 PDT
http://hg.mozilla.org/mozilla-central/rev/842a92bfc110
Comment 7 Andreea Pod 2011-07-13 00:25:56 PDT
Verified fixed on Nightly: Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110712 Firefox/8.0a1 Fennec/8.0a1 

and Aurora: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a2) Gecko/20110711 Firefox/7.0a2 Fennec/7.0a2

Device: LG Optimus 2X

Note You need to log in before you can comment on or make changes to this bug.