Wijmo jquery based scroller not displaying properly in 4.0 beta

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: mikedellav, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

The "What's Happening..." scroller near the bottom of this page is not displaying correctly.  I believe it is a JQuery based scroller which displays fine in all Firefox versions other than the new 4.0 beta. 

Reproducible: Always

Steps to Reproduce:
1. go to this url:  http://www.pressofatlanticcity.com/communities/galloway/
2. scroll 2/4 down the page to the scroller labeled "What's Happening..."
3. View the same page in a previous version of firefox to see the difference in display and functionality.
(Reporter)

Comment 1

8 years ago
i actually meant scroll down 3/4 of the page near the bottom to find the scroller labeled "What's Happening..."

Comment 2

8 years ago
Error console errors on page

Error: $("#grid").wijgrid is not a function
Source File: http://www.pressofatlanticcity.com/communities/galloway/
Line: 1176

Error: assignment to undeclared variable wijInputResult
Source File: http://cdn.wijmo.com/jquery.wijmo-complete.1.0.1.min.js
Line: 18

Error: start is not defined
Source File: http://www.pressofatlanticcity.com/communities/galloway/
Line: 724

Are you the developer? Does fixing those errors resolve the issue?
Whiteboard: TE?
Version: unspecified → Trunk

Comment 3

8 years ago
Regression window(m-c nightly)
Works:
http://hg.mozilla.org/mozilla-central/rev/b7f3c1c9fb57
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091201 Minefield/3.7a1pre ID:20091201052221
Fails:
http://hg.mozilla.org/mozilla-central/rev/68a9b171da30
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091203 Minefield/3.7a1pre ID:20091203044042
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7f3c1c9fb57&tochange=68a9b171da30

Regression window(TM nightly)
Works:
http://hg.mozilla.org/tracemonkey/rev/c84622414ed3
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091119 Minefield/3.7a1pre ID:20091119045932
Fails:
http://hg.mozilla.org/tracemonkey/rev/d689f85f3045
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091202 Minefield/3.7a1pre ID:20091202051636
Pshlog:
http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=c84622414ed3&tochange=d689f85f3045

In localbuild(from TM repository),
build from 595f6db1b7b3 : fails
build from 8808e68c71df : works
Triggered by:
595f6db1b7b3	Jim Blandy — Bug 514560: Forbid assignments to undeclared variables in strict mode code. r=jorendorff
Assignee: nobody → general
Blocks: 514560
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → general
Right, that would cause the "assignment to undeclared variable wijInputResult" bit.

This wijmo library uses "use strict" all over, but is clearly buggy...
Assignee: general → english-us
Component: JavaScript Engine → English US
Product: Core → Tech Evangelism
QA Contact: general → english-us
Whiteboard: TE?
Version: Trunk → unspecified
Note also that this is an out-of-date version of wijmo.  Probably worth trying the current version to see whether it fixes the problem...

Comment 6

8 years ago
There is a changelog here:
https://github.com/wijmo/Wijmo-Complete/blob/master/change.log
...which doesn't mention any fixes since the version used in the site reported in comment 0.

However it only details up to 1.1.2; whereas the latest version is 1.1.3 (I suspect they delay updates to un-paid users to encourage use of their premium package).

Either way, I've emailed robo at wijmo explaining the problem and linking back to this bug.
Summary: jquery based scroller not displaying properly in 4.0 beta → Wijmo jquery based scroller not displaying properly in 4.0 beta
There isn't even a script called wijmo-anything on that page, anymore.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.