Closed Bug 640483 Opened 9 years ago Closed 9 years ago

FF cannot load log in screens in java

Categories

(Core :: Plug-ins, defect, major)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 638171
Tracking Status
blocking2.0 --- -

People

(Reporter: christoffer.valstad, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: 4.0 RC1

Several websites that require java to display a log-in screen cannot find java in mac os x. 

Example of websites:
ttps://secure.skandiabanken.no/skbsecure/Authentication/BankID/Default.aspx
https://nettbank.fokus.no/html/index.html?site=FONB&secsystem=ND

Java is installed. Running Mac OS X 10.6.6

Reproducible: Always

Steps to Reproduce:
1.open website: https://nettbank.fokus.no/html/index.html?site=FONB&secsystem=ND
2.open website: ttps://secure.skandiabanken.no/skbsecure/Authentication/BankID/Default.aspx
Actual Results:  
FF says that additional plugins are required and suggests to download them. 
However, this is not an option as java is included in Mac os x and not downloadable. 

Expected Results:  
FF should load the log-in screen in the website.
The login applet loads fine on both sites for me.
I'm using Firefox 4.0 RC1 on MacOSX 10.5.8
about:plugins says I'm using this Java Plugin:
    File: JavaPlugin2_NPAPI.plugin
    Version: 12.7.0
    Java Plug-In 2 for NPAPI Browsers
About:plugins says Im using:
    
    File: JavaPlugin2_NPAPI.plugin
    Version: 13.4.0
    Java Plug-In 2 for NPAPI Browsers


application/x-java-applet;jpi-version=1.6.0_24 	Java applet 	
application/x-java-applet;version=1.1.3 	Java applet 	
application/x-java-applet 	Basic Java Applets 	javaapplet
application/x-java-applet;version=1.2.2 	Java applet 	
application/x-java-applet;version=1.5 	Java applet 	
application/x-java-vm 	Java applet 	
application/x-java-applet;version=1.3.1 	Java applet 	
application/x-java-applet;version=1.3 	Java applet 	
application/x-java-applet;version=1.1.2 	Java applet 	
application/x-java-applet;version=1.1 	Java applet
The plugin doesn't load for me on 10.6.6 using the RC1, Java Plug-in 2 for NPAPI 13.3.0. There are a ton of warnings in the error console.

The plugin seems to load if I start the browser in 32bit mode, although it doesn't end up doing much. The behavior is different. This feels worthy of nomination.

I'll check if this is a regression.
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Behavior is similar in at least beta 11, so it's not a recent regression.
Is this problem fully reproducible without an account at skandiabanken?

Does it also happen in FF 3.6.15?

Does it also happen on Windows or Linux?
I don't have an account, and the plugin simply does not load on my environment, and I get a gray box with an unhappy lego/plugin face.

This does not happen on 3.6.15 (across OSs). The plugin loads.

This problem does not happen on Windows XP using the RC. The plugin loads a nice looking dialog box. I tried on Linux 64bit and the RC, but no plugins load there, but I think that has to do with Ubuntu integration.
The plugin is asking for version 1.6. AFAICT, the Java Plugin on mac does not claim to support version 1.6, so we don't load it. I don't think there's anything we can do about this, except talk to Apple about getting their Java plugin fixed.
Status: NEW → RESOLVED
blocking2.0: ? → -
Closed: 9 years ago
Resolution: --- → WORKSFORME
If we launch RC in 32bit mode, the plugin loads, see comment #3. It's a workaround, but obviously it would be better if the site were able to fix this on their end.
This now looks like it may be a duplicate of bug 638171
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 638171
You need to log in before you can comment on or make changes to this bug.