Chrome scrollbars stays visible if a context menu show up while panning

VERIFIED FIXED

Status

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: vingtetun, Assigned: vingtetun)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 518384 [details] [diff] [review]
Patch

Steps to reproduce:
 * have many entries into the "All Pages" of the awesome panel
 * do a kinecti pan
 * quickly tap and stay pressed on one entry

Actual result:
 * a context menu show up and the vertical scrollbar is visible on the right side

Expected result:
 * a context menu show up and the vertical scrollbar is gone
Attachment #518384 - Flags: review?(mark.finkle)
Comment on attachment 518384 [details] [diff] [review]
Patch

Should we add the "CancelTouchSequence" code to ContextHelper.showPopup ?
(In reply to comment #1)
> Comment on attachment 518384 [details] [diff] [review]
> Patch
> 
> Should we add the "CancelTouchSequence" code to ContextHelper.showPopup ?

Right, it could prevent spreading this code everywhere.

I just wonder if this make sense since ContextHelper.showPopup could be called outside of a touch sequence?
(In reply to comment #2)
> (In reply to comment #1)
> > Comment on attachment 518384 [details] [diff] [review]
> > Patch
> > 
> > Should we add the "CancelTouchSequence" code to ContextHelper.showPopup ?
> 
> Right, it could prevent spreading this code everywhere.
> 
> I just wonder if this make sense since ContextHelper.showPopup could be called
> outside of a touch sequence?

The "CancelTouchSequence" handler should be prepared for that, imo
Created attachment 518428 [details] [diff] [review]
Patch v0.2

Add the event to ContextHelper.showPopup
Assignee: nobody → 21
Attachment #518384 - Attachment is obsolete: true
Attachment #518384 - Flags: review?(mark.finkle)
Attachment #518428 - Flags: review?(mark.finkle)
Comment on attachment 518428 [details] [diff] [review]
Patch v0.2

Can we add some a test in  browser_scrollbar to test this?
Attachment #518428 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/cf2ab7ef1920

pushed with a test.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 7

8 years ago
VERIFIED FIXED on:

Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:5.0a2) Gecko/20110413 Firefox/5.0a2 Fennec /5.0a

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.