Cannot type into blank address box or Google search boxes (Adobe Reader stealing focus?)

RESOLVED DUPLICATE of bug 537325

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 537325
7 years ago
7 years ago

People

(Reporter: bbhanley5412@comcast.net, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Firefox/4.0

Firefox 4 started fine and would do most things but if I started a new tab, the Address bar, the Google search bar, and the search bar on the Google toolbar would not take the focus. I could not put an insertion point into either one of these text boxes. Therefore I could not type anything in them. This lasted five minutes or more and then everything returned to normal.

Reproducible: Always

Steps to Reproduce:
1.Start Firefox 4
2.Click on any of the above listed text boxes if they are empty.
3.
Actual Results:  
Nothing happened to any empty text box. The faint text (such as "Go to a Web Site" or "Google") did not go away. The insertion point didn't appear in the box. On a new tab I couldn't type in a url.

Expected Results:  
To be able to type in these three fields after clicking on them.
Please try http://support.mozilla.com/en-US/kb/Safe+Mode or if you have the McAfee Sideadvisor addon installed, disable it.

Comment 2

7 years ago
Had you loaded any pdfs or experienced a plugin crash before this happened?
(Reporter)

Comment 3

7 years ago
I think there was a pdf on one of the tabs already open when I started Firefox 4. I received no notice of a plugin crash. I had a new tab already open when Firefox started and it allowed me to type three characters into the Google Toolbar text box then it wouldn't take any more text in any blank field as I originally described regardless of which tab I went to.

I went away to do something else and when I came back some time later everything was working as expected.

In response to Matti: I use Trend Micro for security and I cannot start FF4 in safe mode because I have reverted to version 3. The lack of a Backward/Forward dropdown list was a deal killer as far as I'm concerned.

I may try FF4 again in a couple of months but I don't have time to bother with it at this stage of development.

Comment 4

7 years ago
Changing platform to x86; since WOW64 in user agent indicates 32bit build of Firefox (platform refers to browser build, not OS).

(In reply to comment #3)
> The lack of a Backward/Forward
> dropdown list was a deal killer as far as I'm concerned.

Right click and it's still there.

(In reply to comment #3)
> I may try FF4 again in a couple of months but I don't have time to bother with
> it at this stage of development.

The Firefox 4 release candidate is very likely going to be the exact same build that ships as final, so by "this stage of development" you are referring to what is effectively the final product, which will be shipped within the next week or two.

As such, it would be really helpful if you could try the suggestion in comment 1 and see if it occurs in safe mode. Please could also list the addons installed (copy the output from the page 'about:support').
Hardware: x86_64 → x86
Version: unspecified → Trunk
I think I saw this once with Adobe Reader X, it was completely stealing focus, minimizing and restoring the window fixed the problem.
Not a location bar bug, more like a Plug-in one.
Component: Location Bar → Plug-ins
Product: Firefox → Core
QA Contact: location.bar → plugins

Updated

7 years ago
Summary: Cannot type into blank address box or Google search boxes → Cannot type into blank address box or Google search boxes (Adobe Reader stealing focus?)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 537325
(Reporter)

Comment 7

7 years ago
(In reply to comment #4)
> Changing platform to x86; since WOW64 in user agent indicates 32bit build of
> Firefox (platform refers to browser build, not OS).
> 
> (In reply to comment #3)
> > The lack of a Backward/Forward
> > dropdown list was a deal killer as far as I'm concerned.
> 
> Right click and it's still there.
> 
> (In reply to comment #3)
> > I may try FF4 again in a couple of months but I don't have time to bother with
> > it at this stage of development.
> 
> The Firefox 4 release candidate is very likely going to be the exact same build
> that ships as final, so by "this stage of development" you are referring to
> what is effectively the final product, which will be shipped within the next
> week or two.
> 
> As such, it would be really helpful if you could try the suggestion in comment
> 1 and see if it occurs in safe mode. Please could also list the addons
> installed (copy the output from the page 'about:support').

Thanks for addressing both of my concerns. 

I have discovered that the same focus problem exists in Ver 3, also. If I have a PDF on one of the open tabs when I start Firefox any blank box on any tab will not take the focus. If I kill the tab and then access the same PDF everything works fine. So this is not a new problem. 

I'll try to get Ver 4 installed again soon and check out the Back/Forward button right-click as you suggested. Although, I still don't know why the little open and obvious down-arrow cannot be used. Us old codgers don't appreciate "hidden bonuses" like in Super Mario.

I apologize for the duplicate bug. I searched for this bug to be already recorded but my search terms still left many many bugs to search through and I finally gave up looking.

Comment 8

7 years ago
(In reply to comment #7)
> I have discovered that the same focus problem exists in Ver 3, also. If I have
> a PDF on one of the open tabs when I start Firefox any blank box on any tab
> will not take the focus. If I kill the tab and then access the same PDF
> everything works fine. So this is not a new problem. 

Via about:plugins, could you post what version of adobe reader you have installed? (If it's version 10, could you try the suggestion in comment 35 of bug 537325 and see if it fixes the problem?)
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
I have Adobe Acrobat PDF Plugin version 10.0.1.434 installed.

I'm sorry, but I don't understand "Reader -> Preferences ->
General" from Comment 35 on Bug #537325. 

I don't know where to find the first step, "Reader". I've tried to find something like that, but to no avail.

I'm impressed. You guys are all over this like I'm your only customer.

Comment 10

7 years ago
(In reply to comment #9)
> (In reply to comment #8)
> I have Adobe Acrobat PDF Plugin version 10.0.1.434 installed.
> 
> I'm sorry, but I don't understand "Reader -> Preferences ->
> General" from Comment 35 on Bug #537325. 
> 
> I don't know where to find the first step, "Reader". I've tried to find
> something like that, but to no avail.
> 
> I'm impressed. You guys are all over this like I'm your only customer.

It took me a second too. :) Drop a pdf on your desktop and double click on it opening the stand alone adobe reader view. From there, (menu) Edit -> Preferences option at the bottom, then select the "General" item on the left of the dialog that comes up. In that options panel, find the "Enable Protected Mode at startup" checkbox and uncheck it. Restart. Open Fx, drop a pdf into the first tab and see if the focus problem is still there.
(Reporter)

Comment 11

7 years ago
(In reply to comment #10)
Jim,
Thanks for everything. I did what you said and the problem did not appear when I re-opened Version 3.

I had a PDF already on a tab when I opened Firefox and the problem boxes took the focus. So I closed the tab and re-opened the PDF in a fresh tab. Still everything worked as expected.

I think I'll reload Ver. 4 this afternoon and give it another try.

Thanks,
Bill
(Reporter)

Comment 12

7 years ago
(In reply to comment #10)
Jim,
I opened the PDF in the first tab (I just noticed what you wrote) and had no focus problem doing that either.
You need to log in before you can comment on or make changes to this bug.