Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 640716 - Options of unfocused HTML select claim to be focused
: Options of unfocused HTML select claim to be focused
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- minor (vote)
: mozilla10
Assigned To: alexander :surkov
: alexander :surkov
Depends on: 673958
Blocks: a11ynext
  Show dependency treegraph
Reported: 2011-03-10 12:17 PST by Trevor Saunders (:tbsaunde)
Modified: 2011-09-29 08:02 PDT (History)
4 users (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

test case (981 bytes, text/html)
2011-03-10 12:21 PST, Trevor Saunders (:tbsaunde)
no flags Details

Description Trevor Saunders (:tbsaunde) 2011-03-10 12:17:47 PST
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b13pre) Gecko/20110310 Firefox/4.0b13pre
Build Identifier: 

IF you exaimine the full tree of accessible in the test case for bug 381602 you will find that the first element of the single select and multiple select claim focuse at the same time as well as another odd accessible.  Since the FOCUSED state means the accessible has the keyboard focus, and there can be only one such focus this seems like a bug.

Reproducible: Always
Comment 1 Trevor Saunders (:tbsaunde) 2011-03-10 12:21:50 PST
Created attachment 518486 [details]
test case
Comment 2 David Bolter [:davidb] 2011-03-10 12:32:57 PST
Cc'in Neil in case this bug pops for him.
Comment 3 Trevor Saunders (:tbsaunde) 2011-03-10 21:26:46 PST
I think this may have to do with us forcing the first item of a list to be focused for jaws.  I'm also not sure that this actually ever hurts anyone.
Comment 4 alexander :surkov 2011-09-28 02:24:38 PDT
fixed by bug 673958
Comment 5 Marco Zehe (:MarcoZ) 2011-09-29 08:02:19 PDT
Verified fixed in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110929 Firefox/10.0a1

Note You need to log in before you can comment on or make changes to this bug.