The default bug view has changed. See this FAQ.

JavaScript validation for filing bugs prevents creation of bookmarkable templates with blank mandatory fields (summary, component, etc.)

RESOLVED FIXED in Bugzilla 4.0

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Matt McHenry, Assigned: Max Kanat-Alexander)

Tracking

({regression})

Bugzilla 4.0
regression
Bug Flags:
approval +
approval4.0 +
blocking4.0.1 +
testcase ?

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15 (.NET CLR 3.5.30729)
Build Identifier: 

The JS implemented in bug 490767 is attached to the "Remember values as bookmarkable template" button, but nothing should be mandatory for a template.  This prevents the creation of templates with empty summaries, unspecified components, or empty descriptions.

Reproducible: Always

Comment 1

6 years ago
Confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking4.0.1+
Keywords: regression
Target Milestone: --- → Bugzilla 4.0
Version: unspecified → 4.0
(Assignee)

Comment 2

6 years ago
Created attachment 526541 [details] [diff] [review]
v1

Simple enough to fix. :-) (Small patch.)
Assignee: create-and-change → mkanat
Status: NEW → ASSIGNED
Attachment #526541 - Flags: review?(reed)
Attachment #526541 - Flags: review?(guy.pyrzak)

Comment 3

6 years ago
Comment on attachment 526541 [details] [diff] [review]
v1

Review of attachment 526541 [details] [diff] [review]:

works for me. I'd prefer to pass in a variable, but since we're using onsubmit for the form i can't think of a better way to handle this.
Attachment #526541 - Flags: review?(guy.pyrzak) → review+
(Reporter)

Comment 4

6 years ago
I just applied the patch on our installations, and it works great.  Thanks!
(Assignee)

Updated

6 years ago
Flags: approval4.0+
Flags: approval+
(Assignee)

Updated

6 years ago
Attachment #526541 - Flags: review?(reed)
(Assignee)

Comment 5

6 years ago
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/                       
modified js/field.js
modified template/en/default/bug/create/create.html.tmpl
Committed revision 7794.

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/4.0/                         
modified js/field.js
modified template/en/default/bug/create/create.html.tmpl
Committed revision 7580.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Flags: testcase?
You need to log in before you can comment on or make changes to this bug.