Last Comment Bug 640889 - [Firefox] WinXP debug permaorange: "test_leaf_layers_partition_browser_window.xul | Leaf layers should form a non-overlapping partition of the browser window"
: [Firefox] WinXP debug permaorange: "test_leaf_layers_partition_browser_window...
Status: RESOLVED FIXED
[perma-orange]
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: mozilla6
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: 632408 614955
  Show dependency treegraph
 
Reported: 2011-03-10 23:37 PST by Phil Ringnalda (:philor)
Modified: 2011-05-17 06:49 PDT (History)
5 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
some breathing room (1.59 KB, patch)
2011-03-12 21:43 PST, Phil Ringnalda (:philor)
tnikkel: review+
Details | Diff | Splinter Review
fix (3.75 KB, patch)
2011-05-16 03:58 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
tnikkel: review+
Details | Diff | Splinter Review

Description Phil Ringnalda (:philor) 2011-03-10 23:37:01 PST
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1299774157.1299777108.3542.gz&fulltext=1#err0
Rev3 WINNT 5.1 mozilla-central debug test mochitest-other on 2011/03/10 08:22:37
s: talos-r3-xp-020

...
7556 INFO TEST-PASS | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | Waiting for mozPaintCount to increase. - 0 should equal 0
7557 INFO TEST-PASS | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | mozPaintCount has increased - 1 should not equal 0
7558 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | Leaf layers should form a non-overlapping partition of the browser window

No idea how to tell whether or not this is the same thing as bug 632408, where it permafails on SeaMonkey's (debug-only) Win2K3 boxes.
Comment 1 Armen Zambrano [:armenzg] (EDT/UTC-4) 2011-03-11 08:12:19 PST
roc and tnikkel could we disable this test so we can unhide the whole suite?

I would like to reveal the suite while we figure out how to fix this test failure.
Comment 2 Serge Gautherie (:sgautherie) 2011-03-11 11:21:09 PST
Bug 632408 comment 5:
{
Timothy Nikkel (:tn)      2011-03-11 02:11:18 PST

If you set the environment variable MOZ_DUMP_PAINT_LIST to 1 you will get a lot
of paint debug output including a dump of the layer tree. The layer tree dump
would probably useful in determining why this is failing.
}
Comment 3 Timothy Nikkel (:tnikkel) 2011-03-11 15:13:16 PST
So the reason this fails is that the resizer has a layer that overlaps the content layer. Windows Vista/7 resize via a thick border and don't have the resizer.
Comment 4 Timothy Nikkel (:tnikkel) 2011-03-11 16:43:32 PST
Since on both XP and Vista/7 our browser window has significant differences we should probably run the test twice, once with a maximized window and once without. (XP has a resizer only when not maximized, and the tabs move up higher on a maximized window on Vista/7.)
Comment 5 Timothy Nikkel (:tnikkel) 2011-03-11 19:17:15 PST
The resizer layer is 17x17, so I don't think we have a problem here. The question is how to modify the test properly.
Comment 6 Phil Ringnalda (:philor) 2011-03-12 21:43:36 PST
Created attachment 518996 [details] [diff] [review]
some breathing room

This'll keep me from constantly badgering you about when you'll figure out a way to deal with the resizer, and when I can make the suite visible, and when you're going to work on it, and how the work on it is going, and whether you've come up with an idea yet, and when...
Comment 7 Phil Ringnalda (:philor) 2011-03-12 21:59:17 PST
http://hg.mozilla.org/mozilla-central/rev/a7c8c8e4d928
Comment 8 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-13 14:17:46 PDT
(In reply to comment #5)
> The resizer layer is 17x17, so I don't think we have a problem here. The
> question is how to modify the test properly.

Let's just not run the non-fullscreen test on < Vista.
Comment 9 Timothy Nikkel (:tnikkel) 2011-03-13 15:00:07 PDT
Is there an (easy) way to maximize a window? I spent some time looking but failed to find a way.
Comment 10 Phil Ringnalda (:philor) 2011-03-13 15:07:42 PDT
http://mxr.mozilla.org/mozilla-central/source/widget/tests/window_state_windows.xul#99 seems to say "get it through nsIWindowMediator, then call win.maximize()"
Comment 11 Timothy Nikkel (:tnikkel) 2011-03-14 00:59:25 PDT
Thanks Phil!
Comment 12 Treeherder Robot 2011-03-14 05:47:03 PDT
ted.mielczarek%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Build-System/1299812000.1299815159.15154.gz
Rev3 WINNT 5.1 build-system debug test mochitest-other on 2011/03/10 18:53:20

s: talos-r3-xp-040
7558 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | Leaf layers should form a non-overlapping partition of the browser window
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/dom/tests/browser/browser_focus_steal_from_chrome.js | Exited with code -1073741819 during test run
PROCESS-CRASH | chrome://mochitests/content/browser/dom/tests/browser/browser_focus_steal_from_chrome.js | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | missing output line for total leaks!
TEST-UNEXPECTED-FAIL | plugin process 4084 | automationutils.processLeakLog() | missing output line for total leaks!
Comment 13 Treeherder Robot 2011-03-14 08:56:07 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1299901449.1299902736.11344.gz
Rev3 WINNT 5.1 mozilla-central debug test mochitest-other on 2011/03/11 19:44:09

s: talos-r3-xp-043
7558 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | Leaf layers should form a non-overlapping partition of the browser window
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 14 Treeherder Robot 2011-03-14 08:56:15 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1299910993.1299912402.12980.gz
Rev3 WINNT 5.1 mozilla-central debug test mochitest-other on 2011/03/11 22:23:13

s: talos-r3-xp-014
7558 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | Leaf layers should form a non-overlapping partition of the browser window
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 15 Treeherder Robot 2011-03-14 08:56:25 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1299893303.1299894696.11676.gz
Rev3 WINNT 5.1 mozilla-central debug test mochitest-other on 2011/03/11 17:28:23

s: talos-r3-xp-052
7558 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | Leaf layers should form a non-overlapping partition of the browser window
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 16 Treeherder Robot 2011-03-14 08:56:34 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1299889847.1299891178.30474.gz
Rev3 WINNT 5.1 mozilla-central debug test mochitest-other on 2011/03/11 16:30:47

s: talos-r3-xp-007
7558 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | Leaf layers should form a non-overlapping partition of the browser window
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 17 Treeherder Robot 2011-03-14 08:56:45 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1299890532.1299891874.553.gz
Rev3 WINNT 5.1 mozilla-central debug test mochitest-other on 2011/03/11 16:42:12

s: talos-r3-xp-011
7558 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | Leaf layers should form a non-overlapping partition of the browser window
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 18 Treeherder Robot 2011-03-30 17:56:51 PDT
sgautherie.bz%free.fr
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox4.0/1301525059.1301526400.10599.gz
Rev3 WINNT 5.1 mozilla-2.0 debug test mochitest-other on 2011/03/30 15:44:19

s: talos-r3-xp-036
7218 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/text/tests/test_bug636465.xul | Setting the spellcheck attribute back to true should work
7558 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | Leaf layers should form a non-overlapping partition of the browser window
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 19 Treeherder Robot 2011-03-30 20:00:04 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox4.0/1301538342.1301539824.5753.gz
Rev3 WINNT 5.1 mozilla-2.0 debug test mochitest-other on 2011/03/30 19:25:42

s: talos-r3-xp-027
7558 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | Leaf layers should form a non-overlapping partition of the browser window
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 20 Treeherder Robot 2011-03-30 21:03:59 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox4.0/1301542188.1301543597.20466.gz
Rev3 WINNT 5.1 mozilla-2.0 debug test mochitest-other on 2011/03/30 20:29:48

s: talos-r3-xp-021
7558 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/base/test/chrome/test_leaf_layers_partition_browser_window.xul | Leaf layers should form a non-overlapping partition of the browser window
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 21 Phil Ringnalda (:philor) 2011-03-31 17:43:17 PDT
Breathing room on 2.0: http://hg.mozilla.org/releases/mozilla-2.0/rev/a540041afe0a
Comment 22 Daniel Veditz [:dveditz] 2011-04-01 11:02:44 PDT
There were a couple of green mozilla2.0 cycles before this landed (despite summary claiming permaorange), and since then we've seen bug 637975 as a perma-orange
Comment 23 Phil Ringnalda (:philor) 2011-04-01 12:40:17 PDT
Excuse me? Neither one of those assertions seems to be at all true. Log links or it didn't happen.
Comment 26 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-05-16 03:58:54 PDT
Created attachment 532599 [details] [diff] [review]
fix
Comment 27 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-05-16 03:59:19 PDT
(In reply to comment #25)

Looks like mrbkap backed some stuff out to fix those failures.
Comment 28 Mounir Lamouri (:mounir) 2011-05-17 06:49:32 PDT
Pushed once:
http://hg.mozilla.org/mozilla-central/rev/c0f9a84ffb2d

Then backed out because the bug number was incorrect:
http://hg.mozilla.org/mozilla-central/rev/1205e0437f0a

Then pushed again:
http://hg.mozilla.org/mozilla-central/rev/f792fa7755dc

Note You need to log in before you can comment on or make changes to this bug.