Cache folders are created in the roaming profile rather than the local profile

RESOLVED WONTFIX

Status

Testing
ProfileManager
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: Danial Horton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15 GTB7.1
Build Identifier: 

Profiles that are launched via the profile manager create the cache folders within the Roaming appdata folder instead of the local appdata folder.

launching the same profile with -p -no-remote create the cache folders in the normal location.

Reproducible: Always

Steps to Reproduce:
1. Add a profile to the profile manager app
2. Start that profile
3. Note the cache, startupcache and offline cache folders are created in the Roaming profile instead of the local profile.
Actual Results:  
cache folders are created at c:\Users\*user*\AppData\Roaming\Mozilla\Firefox\Profiles\*Profile*\ instead of c:\Users\*user*\AppData\Local\Mozilla\Firefox\Profiles\*Profile*\

Expected Results:  
cache folders to be placed in the same location regardless of direct launching or launching from profile manager
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [blocker-1.0]
This appears to be a limitation in Firefox.   If you launch Firefox with a named profile (i.e., -P profilename), the cache folders get created in the local appdata folder.

If you launch Firefox with a profile path (i.e., -profile /path/to/profile), the cache folders get created within that folder (not in the local appdata folder).

ProfileManager launches Firefox using the latter method, since at some point in the future, it appears that support for -P may be removed from the product.

Marking this as WONTFIX for now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Whiteboard: [blocker-1.0]

Updated

6 years ago
Duplicate of this bug: 691155

Comment 3

6 years ago
This shouldn't have been closed.

It's a dup of 517425 and it is still open.
You need to log in before you can comment on or make changes to this bug.