Last Comment Bug 641010 - crash [@ libdvm.so@0x35790][@ libdvm.so@0x35748 ][@ libdvm.so@0x35784 ][@ libdvm.so@0x357d0 ]
: crash [@ libdvm.so@0x35790][@ libdvm.so@0x35748 ][@ libdvm.so@0x35784 ][@ lib...
Status: RESOLVED FIXED
: crash
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: Trunk
: ARM Android
: -- critical (vote)
: ---
Assigned To: Doug Turner (:dougt)
:
: Jim Chen [:jchen] [:darchons]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-11 09:58 PST by Thomas Arend [:tarend]
Modified: 2011-06-09 14:58 PDT (History)
8 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
5+


Attachments
patch v.1 (6.83 KB, patch)
2011-05-23 16:17 PDT, Doug Turner (:dougt)
mwu.code: review+
mark.finkle: approval‑mozilla‑aurora+
mark.finkle: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Thomas Arend [:tarend] 2011-03-11 09:58:10 PST
This bug was filed from the Socorro interface and is 
report bp-f46cdd8c-4833-47ec-a58e-97bcb2110311 .
============================================================= 
This happens wjen long-tapping on a url and selecting copy
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-03-14 10:23:22 PDT
Sounds like a dupe of bug 640337

*** This bug has been marked as a duplicate of bug 640337 ***
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2011-03-14 10:26:45 PDT
all these crash reports came in the day after 640337 landed, so I don't think its a dupe.

However, all these crash reports were for one build only, so it looks like it is a dupe of something that landed on 3/10.
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2011-03-14 10:27:15 PDT
so... resolving works for me since this fell off the crash stats
Comment 5 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2011-03-29 12:53:43 PDT
Firefox Mobile 4.0 RC 1 build 3, Android 2.3.3 (Google Nexus)

Copying the url from urlbar causes a crash.

Steps to reproduce:
1. Launch Firefox Mobile.
2. Open a website, e.g. mozilla.com
3. Click into the urlbar to get into edit mode.
4. Click and hold for getting the context menu, choose copy.

A second later or so the applications crashes.
Comment 6 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2011-03-29 12:54:33 PDT
It also happens in a new profile create with the 'Mobile Profiles' extension. Here is the crash from my default profile: https://crash-stats.mozilla.com/report/index/7fc2f882-249b-4447-be41-c609c2110329
Comment 7 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2011-04-04 11:30:02 PDT
This happens also using the Link2Clipboard extension which simply copies a link url to the clipboard (before crashing). So sound like a clipboard issue (in Fennec or Android).
Comment 8 Josh Matthews [:jdm] (on vacation until Dec 5) 2011-04-04 11:34:02 PDT
Archaeopteryx, where can Link2Clipboard be found?  I don't see it when searching on AMO.
Comment 9 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2011-04-04 11:44:44 PDT
Wasn't yet visible as no editor hadn't yet reviewed it. You find it here:
https://addons.mozilla.org/mobile/addon/link2clipboard/
Comment 10 Scoobidiver (away) 2011-04-04 13:37:19 PDT
I added other related crash signatures to the summary.
With combined signatures, it is a virtual #16 top crasher in 4.0 over the last 3 days.

More reports at:
https://crash-stats.mozilla.com/query/query?product=Fennec&version=Fennec%3A4.0&platform=linux&branch=2.0&range_value=1&range_unit=weeks&query_search=signature&query_type=startswith&query=libdvm.so@0x357&build_id=&process_type=any&hang_type=any&do_query=1
Comment 11 Josh Matthews [:jdm] (on vacation until Dec 5) 2011-04-07 08:47:38 PDT
Doug/Brad, could this be a result of a missing |AutoLocalJNIFrame jniFrame;| in AndroidBridge::SetClipboardText?
Comment 12 Doug Turner (:dougt) 2011-04-07 09:12:58 PDT
wouldn't that result in a java crash?
Comment 13 Aaron Train [:aaronmt] 2011-05-03 08:17:38 PDT
(In reply to comment #5)
> Firefox Mobile 4.0 RC 1 build 3, Android 2.3.3 (Google Nexus)
> 
> Copying the url from urlbar causes a crash.
> 
> Steps to reproduce:
> 1. Launch Firefox Mobile.
> 2. Open a website, e.g. mozilla.com
> 3. Click into the urlbar to get into edit mode.
> 4. Click and hold for getting the context menu, choose copy.
> 
> A second later or so the applications crashes.

I reproduced this, albeit once on today's nightly 05/03. Still seems like an issue, as Aakash points out http://input.mozilla.com/en-US/opinion/2011891
Comment 14 Doug Turner (:dougt) 2011-05-23 16:12:56 PDT
Program received signal SIGSEGV, Segmentation fault.
0x80035790 in dvmMarkObjectNonNull () from /builds/android_tools/tegra-gdb-20100902/lib/libdvm.so
(gdb) bt
#0  0x80035790 in dvmMarkObjectNonNull () from /builds/android_tools/tegra-gdb-20100902/lib/libdvm.so
#1  0x80052060 in ?? () from /builds/android_tools/tegra-gdb-20100902/lib/libdvm.so
#2  0x80052060 in ?? () from /builds/android_tools/tegra-gdb-20100902/lib/libdvm.so


nothing on adb logcat.


Looks like we are passing back a string to java that isn't null terminated.  patching coming up....
Comment 15 Doug Turner (:dougt) 2011-05-23 16:17:47 PDT
Created attachment 534613 [details] [diff] [review]
patch v.1

I went through the file looking for other uses and also found a few places where we don't have a jni frame on the stack.  I fixed that up.
Comment 16 Doug Turner (:dougt) 2011-05-24 09:37:17 PDT
http://hg.mozilla.org/mozilla-central/rev/9eae975b3d6f
Comment 17 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-25 07:46:19 PDT
Comment on attachment 534613 [details] [diff] [review]
patch v.1

android-only crash fix
Comment 18 Scoobidiver (away) 2011-05-25 07:57:12 PDT
From today, we are in Firefox 6 Aurora.
If this patch is wanted for Firefox 5 mobile, it should be landed on Beta.
Comment 19 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-25 08:56:49 PDT
Comment on attachment 534613 [details] [diff] [review]
patch v.1

Android-only. Wanted for Fx5.
Comment 21 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-25 10:42:31 PDT
http://hg.mozilla.org/releases/mozilla-beta/rev/0ba4cd9abe00

Note You need to log in before you can comment on or make changes to this bug.