Closed Bug 641064 Opened 11 years ago Closed 10 years ago

Pressing Alt+D on Location Bar doesn't select entire address

Categories

(SeaMonkey :: Location Bar, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: tar, Assigned: neil)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110310 Firefox/4.0b13pre SeaMonkey/2.1b3pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110310 Firefox/4.0b13pre SeaMonkey/2.1b3pre

Alt+D doesn't select entire urlbar text when focus is in the urlbar.

Reproducible: Always

Steps to Reproduce:
1. Focus location bar (Alt+D, Ctrl+L, F6, mouseclick...)
2. Type something
3. Press Alt+D
Actual Results:  
No changes in selection.

Expected Results:  
All the text is selected.

Working as expected in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.17pre) Gecko/20110122 SeaMonkey/2.0.12pre
Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110228 Firefox/4.0b13pre
Version: unspecified → Trunk
The only relevant change appears to be Bug 501445 - Accessible name for location bar is inconsistent or misbehaving.
Reverting Bug 501445 changes doesn't fix the Alt+D behavior.
> The only relevant change appears to be Bug 501445 - Accessible name for
> location bar is inconsistent or misbehaving.
Nope that's incorrect.

Can you find a regression range? Does this bug appear in 2.1b1? a3/a2/a1?
Status: UNCONFIRMED → NEW
Ever confirmed: true
The bug is present since first 2009-07-12-06-comm-central-trunk build rv:1.9.2a1pre Gecko/20090712 SeaMonkey/2.1a1pre, but not on comm-1.9.1 branch of that time.
The focus manager landed since 1.9.1; it might optimise the case of focusing a field that is already focused so that it doesn't trigger a select all.
Note: This doesn't affect Firefox because they use explicit <key>s to map both CTRL-L and ALT-D to "Browser:OpenLocation"
I'm porting the Firefox fix in Bug 639202.
Depends on: 639202
Attached patch WorkaroundSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #611066 - Flags: review?(philip.chee)
Comment on attachment 611066 [details] [diff] [review]
Workaround

>diff --git a/suite/browser/urlbarBindings.xml b/suite/browser/urlbarBindings.xml

>+      <handler event="keypress"
>+               key="&locationBar.accesskey;"
>+               modifiers="access"
>+               action="this.select();"/>

I actually tried this earlier in Bug 639202 but kept getting entity undefined errors. I probably added the wrong file to the DOCTYPE. :P

By the way when is gURLBar.readOnly set to true? I can't find anything that sets it.
Attachment #611066 - Flags: review?(philip.chee) → review+
Pushed changeset 9fae321b8d21 to comm-central.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
No longer depends on: 639202
You need to log in before you can comment on or make changes to this bug.