Last Comment Bug 641195 - Make about:licence work again, or remove the vestiges of it (about:license is not affected)
: Make about:licence work again, or remove the vestiges of it (about:license is...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla7
Assigned To: Steffen Wilberg
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 322000 data-driven-compreg
Blocks: 538926
  Show dependency treegraph
 
Reported: 2011-03-12 02:57 PST by Steffen Wilberg
Modified: 2011-06-28 03:07 PDT (History)
5 users (show)
steffen.wilberg: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix it (1.74 KB, patch)
2011-03-14 13:22 PDT, Steffen Wilberg
benjamin: review-
Details | Diff | Splinter Review
nuke it (35.54 KB, patch)
2011-06-20 14:48 PDT, Steffen Wilberg
benjamin: review+
Details | Diff | Splinter Review

Description Steffen Wilberg 2011-03-12 02:57:24 PST
Bug 322000 introduced about:licence in addition to about:license. It uses the same html page, with a correctSpelling() function.

During a large component registration rewrite, bug 568691 removed the contract (or whatever it is called) of about:licence, i.e. the line corresponding to this one in nsDocShellModule.cpp:
{ NS_ABOUT_MODULE_CONTRACTID_PREFIX "license", &kNS_ABOUT_REDIRECTOR_MODULE_CID },

about:licence is no longer listed in about:about, and entering it in the location bar results in an error dialog. about:license works fine.

So we should either add the above mentioned line for "licence" as well.
Or remove the vestiges of "about:licence" from nsAboutRedirector.cpp:
  { "licence", "chrome://global/content/license.html",
    nsIAboutModule::URI_SAFE_FOR_UNTRUSTED_CONTENT },
and remove correctSpelling() and the "correctme" classes from license.html.

Fight for the correct spelling, or remove the bloat?
Comment 1 Gervase Markham [:gerv] 2011-03-12 04:39:35 PST
I originally wrote this code, and I'd like to see it fixed :-)

Gerv
Comment 2 Gervase Markham [:gerv] 2011-03-14 04:52:47 PDT
Steffen: it doesn't sound to be like this patch would be complicated. Are you able to make it?

Sadly, it's probably too late for FF4...

Gerv
Comment 3 Steffen Wilberg 2011-03-14 13:22:09 PDT
Created attachment 519222 [details] [diff] [review]
fix it

Just the one line I mentioned in comment 0 already.
Comment 4 Benjamin Smedberg [:bsmedberg] 2011-03-15 13:01:08 PDT
I really don't like having to maintain two variants, although removing one was an oversight on my part originally. Since none of the other names of about: URIs are localized, I really don't see why this one should be. I think we should remove all the supporting bits of the licence variant.
Comment 5 Gervase Markham [:gerv] 2011-03-16 06:20:53 PDT
None of the names are localized into other languages, because about: URIs are specified in English. However this is the only one using a word whose spelling differs between British (and Canadian, Australian and Indian) English and US English. about:license is correct for you, about:licence is correct for me.

This is a small demonstration of the Mozilla project's non-US-centredness, and I would like it to be retained.

(Of course, in hindsight, we would have called it "about:licensing" way back, and avoided this problem. But here we are.)

Gerv
Comment 6 Steffen Wilberg 2011-03-16 12:14:11 PDT
Renaming it to about:licensing would be simple, and it would still be accessible through the About dialog and about:about even if you don't know about the name change.

However, it would break correctSpelling(), which checks if it was loaded as about:license or about:licence. But that's a questionable idea anyway: it's called e.g. the "GNU General Public License", not Licence. The text of the licenses don't get "corrected", only the license titles and some introductory notes.

But if we remove correctSpelling(), the mere doubling of the page location is pretty moot, isn't it?
Comment 7 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-03-16 12:46:14 PDT
I agree with Benjamin - this folly needs to stop :) The "small demonstration of the Mozilla project's non-US-centredness" is not worth the code it requires.
Comment 8 Gervase Markham [:gerv] 2011-03-16 13:45:35 PDT
OK; let's remove about:license and leave about:licence. :-)

Gerv
Comment 9 Steffen Wilberg 2011-06-20 14:48:51 PDT
Created attachment 540597 [details] [diff] [review]
nuke it

Sorry Gerv...
Comment 11 Mounir Lamouri (:mounir) 2011-06-27 02:08:46 PDT
Merged:
http://hg.mozilla.org/mozilla-central/rev/8be930c2f3c2
Comment 12 Steffen Wilberg 2011-06-27 03:30:45 PDT
in-testsuite-, no need to test the removal of about:licence.

Note You need to log in before you can comment on or make changes to this bug.