Webm videos play like a sticky record

VERIFIED DUPLICATE of bug 669556

Status

()

--
major
VERIFIED DUPLICATE of bug 669556
8 years ago
7 years ago

People

(Reporter: simon.bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b13pre) Gecko/20110312 Firefox/4.0b13pre
Build Identifier: 

I'm experiencing webm playback issues - Video will play fine for the first minute or so, the video then pauses and sound plays like a stuck record, then a couple of seconds later plays some more video, and video and audio pauses again and again.

Please see linked MP4 video.

This happens every time with webm videos from Youtube and Vimeo. I haven't tested any other service or local videos.

Running a Mac with OS X 10.6.6, tried nightly trunk and 4.0 RC. I have had this problem for over a week.

Reproducible: Always

Comment 1

8 years ago
I have similar issue on Windows Vista for 720p WebM videos

1. goto http://www.youtube.com/watch?v=kJ8HFicQoD4&html5=1
2. ensure the video is HTML5, 
   by right clicking and see the context menu not adobe flash 
3. Switch from 360 to 720p
4. Wait (< 1 minute) to see video start skipping while playing

Mozilla/5.0 (Windows NT 6.0; rv:2.0b13pre) 
Gecko/20110303 Firefox/4.0b13pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
Simon, can you please provide a link to a video that shows the problem for you?

I can't reproduce Biju's problem locally on a Linux machine (after waiting for the video to buffer completely--my link is too slow to stream the video), I'll try Windows 7 shortly.
(Reporter)

Comment 3

8 years ago
Created attachment 519816 [details]
iFrame embedded video

An example for comment 2. You may have to let it play for a minute or so.
(Reporter)

Comment 4

8 years ago
Ok, I have been informed the video may not play externally in some countries.

Link to Youtube is http://www.youtube.com/embed/oHg5SJYRHA0.
(Reporter)

Comment 5

8 years ago
I have tried the link in comment 1. Method described triggers this bug every time for me. Switching back to 360p has the same effect.
Biju, are you sure it's not just pausing to buffer very frequently?  That video downloads very slowly for me (around 0.3 - 0.5 the speed necessary to play back in realtime).  YouTube's controls don't have any UI to indicate that it's paused for buffering.

I'll try to reproduce Simon's issue on an OS X machine today.

Comment 7

8 years ago
Created attachment 520145 [details]
histogram.png

URL 1 : http://www.youtube.com/watch?v=kJ8HFicQoD4&html5=1 
URL 2 : http://www.youtube.com/watch?v=qjCLQaTFXx0&html5=1
URL 3 : http://tinyvid.tv/show/ah2ebubqurvy 

While testings I have enabled controls on video and see it is buffered "enough" before playing, but remember is it is still downloading rest of video and still there is enough to play. 
On audio, I dont notice that much problem.
 
I think am seeing two issues or three here.

Issue 1.
========
That happened only for URL 1, and now I am unable to reproduce this case. 
I think I found reason why it was happening, the issue show up when ccApp.exe (Symantec User Session) is running. Some time it consume 15% to 30% of the CPU time. And normally this app is hidden in Vista Task Manager. And URL 1 at 720p consumes 70% CPU, sometimes even upto 80%.
So it choke CPU

Strangely URL 2 at 720p or URL 3 will not go over 60% on my PC

So I wonder why the first URL 1 consume more CPU resource?
I wish we can perform as fast as 720p Adobe Flash. 


Issue 2.
========
At full screen, when URL 1, 2, 3 play (to some extend even 1 and 2 at 360p) it plays good for say 3 seconds then video get stuck 1 or 2 seconds then play again after skipping to catch up with audio. Occasionally audio also stuck for 1 second or so.

This is different from how flash do full screen, flash show at least a frame every second when doing catch up. Also this is how we do in Fx 3.6 for URL 3.
So I feel this is a regression of Bug 494120 
Also when this happens average CPU is below 100%, but histogram show we are fluctuating a lot and hitting 100% in Fx 4, while in Fx3.6 it stay almost flat like the flash do.
Please see attachment histogram.png  I have dual core both shows almost same load.


Issue 3.
========
This happens for all three URLs. Even at normal (not full screen) size when the video is being downloaded I see slight, but noticeable skipping. Here avg CPU is below 100% and histogram also looks good.
Issue is similar to Bug 499554

(In reply to comment #6)
> Biju, are you sure it's not just pausing to buffer very frequently?  

Confirming it is not pausing to buffer.

> That video downloads very slowly for me 
> (around 0.3 - 0.5 the speed necessary to play back
> in realtime).  YouTube's controls don't have any UI to indicate that it's
> paused for buffering.

do about config dom.event.contextmenu.enabled = false
and enable controls
Blocks: 669556
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669556
Status: RESOLVED → VERIFIED
No longer blocks: 669556
You need to log in before you can comment on or make changes to this bug.