Extracted comments are not always displayed

RESOLVED FIXED

Status

Webtools Graveyard
Verbatim
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: iacchi, Unassigned)

Tracking

Details

(Whiteboard: [better verbatim])

(Reporter)

Description

7 years ago
Sometimes in a string to be translated, before the English text, there's a tip that let you know something useful for the string translation (e.g. "the string must be 20 chars long maximum" or "%s will be replaced with the product name"). This tip disappears when you translate the string and accept the translation.
This is a bad behaviour because sometimes you're forced to do a not perfect translation in order to meet the string requirements (e.g. a good translation would take 28 chars but there's a limit of 20), but a reviewer may just think that you've done a bad translation and correct it if he/she can't see the tip and understand the reason you've translated that way or even yourself, while reviewing your translation some time later, may correct that string if you don't remember that there was a limit on it (and you probaly won't remember it).
This said, it would be great to have this tip permanent on the string, and not disappearing.
These tips are l10n comments extracted from the source files.  In the PO file, they're prefixed with "#."

(In reply to comment #0)
> This tip disappears when you translate the string and accept the translation.

Iacopo and I tested this on IRC, and sadly, it's not that simple.

We're still trying to find a string in which the L10n comment would work for one of us but not for the other.  I'll update this bug if we find anything.
Summary: Translation tip for a string disappears as the string is translated → Extracted comments are not always displayed
OK, so here are the steps to reproduce:

1. Find a string which has an l10n comment, e.g. https://localize.mozilla.org/it/twitterparty/LC_MESSAGES/messages.po/translate/?unit=865971 (it can be used only once).

2. Click "Submit".  The translation can be empty or not.

3. Verbatim will show you the next string in the file.  Go back to the string you just edited.

Expected results:

The l10n comment is still there.

Actual results:

The comment is gone, globally.  All users accessing this string will not see it.

As reported by Iacopo, the comment seems to come back after some time (today was one week after Iacopo first saw the issue, and we were able to see it again on the same strings).
What is the status of this bug? I do not have access to Verbatim so cannot verify
Whiteboard: [better verbatim]

Comment 4

6 years ago
I tried to duplicate this issue with the upcoming development version of Pootle. I tried a few different scenarios, and couldn't duplicate this. The original file isn't available any more, but I can't think of a reason why this would be a data dependent bug. A lot of things changed on the translate page for the upcoming version, so it sounds reasonable that we probably fixed this on the way. This should be fixed with the upgrade to the upcoming version of Pootle.

Comment 5

6 years ago
Marking this as fixed then.

iacchi -> if you are able to try and test when we deploy the new Pootle server that would be a great help.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.