Note: There are a few cases of duplicates in user autocompletion which are being worked on.

XUL-based UI: fail to render non-English text in menu & menuitems

VERIFIED FIXED in M10

Status

()

Core
XUL
P3
blocker
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: tao, Assigned: saari (gone))

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
On apr-27-99's build, apprunner failed to render non-English text
in menu & menuitems.

To reproduce it, you'll need to set up your workstation to support
non-ascii font if they are not there yet. I was told that this is a
known problem. If so, please make it a dup.

Shall you need assistance in reproducing the problem, feel free to
contact me or momoi.

Thanks
(Reporter)

Comment 1

19 years ago
Created attachment 182 [details]
The navigator.xul, which contains JA text, used to produce the problem

Comment 2

19 years ago
My sample translations of Menu and Menuitems are showing

correctly as Japanese with 5/7/99 Win32 M6 build.

I

Comment 3

18 years ago
My sample .xul file was used on Japanese Windows and where these
Japanese characters will be displayed correctly. But this is not
true on US Windows or any other language Windows since the menus are
using Native widgets.
So this still remains a problem.ˇ
(Reporter)

Comment 4

18 years ago
Changing QA contact to myself

Comment 5

18 years ago
This also affects having international data in the menus for
  Go, Bookmarks and What's Related

Book Marks and What's Related sill display correctly in the sidebar,
but without this fix, they will display as garbage in the menus.

Updated

18 years ago
Assignee: trudelle → saari

Comment 6

18 years ago
reassigning to saari
(Reporter)

Comment 7

18 years ago
Hi, Saai:

Would you please consider fixing this problem by M7? L10n group will start
 localization work by M7. Please feel free to let us know if we can be of any
 help.


Thanks
(Assignee)

Comment 8

18 years ago
Yep, I'll take a look.
(Assignee)

Comment 9

18 years ago
So what should menus do when they have international text on a non-international
system? (I don't even know if MacOS for example can do this at all)

In particular is there a different OS call I should be making?

Comment 10

18 years ago
see bug #5402 for a patch to fix this on the mac.
(Assignee)

Updated

18 years ago
Target Milestone: M7
(Assignee)

Comment 11

18 years ago
This is a dup 5402 and should be fixed now...
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

18 years ago
Does this mean the problem is fixedon Linux as well? How about other native
widgets such as FilePicker and others/

Comment 13

18 years ago
No, Tague fixed it for the Mac only. This bug report is for all platforms, but
it would be easier to process if it was for a single platform. This bug report
is for menus and menu items, not the file picker and others.
(Assignee)

Comment 14

18 years ago
Menus should be ok on Windows and Mac now. GTK doesn't have international support
yet, and won't until 1.4 or so.

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 15

18 years ago
In that case, we should keep this bug open until Linux issue is
resolved.

Updated

18 years ago
Resolution: FIXED → ---

Comment 16

18 years ago
erik, is there a workaround for this? Can we not display Japanese
menu/menu items using native widgets there with the assumption that
the .xul file is in UTF-8.

Comment 17

18 years ago
GTK does not support Unicode directly. It may do so in 1.3/1.4. In the meantime,
we are first going to support the current locale (e.g. Japanese), and maybe in
the future multilingual menus if possible. Japanese does not work in Mozilla
GTK menus yet.

Updated

18 years ago
Blocks: 7228
(Assignee)

Updated

18 years ago
Target Milestone: M7 → M8
(Assignee)

Comment 18

18 years ago
pushing to M8 to keep on the near term radar
(Assignee)

Updated

18 years ago
Target Milestone: M8 → M10
(Assignee)

Comment 19

18 years ago
Still an issue, but setting target M10
(Assignee)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 20

18 years ago
Ok, Mac menus are as internationalized as they are going to get, and we have
XPMenus on the other platforms that should be international safe.

Marking fixed.
(Reporter)

Updated

18 years ago
Depends on: 11724
(Reporter)

Comment 21

18 years ago
There is a XML parser problem in M9 that will cause Mozilla to crash
in loading UTF-8 encoded DTD files. Therefore, I won't be able to verify
this fix until that bug is fixed.
(Reporter)

Updated

18 years ago
QA Contact: tao → blee
(Reporter)

Comment 22

18 years ago
Verified on Linux and NT builds. Reassign QA contact to Bom-Sheek to verify it
on Mac.

Comment 23

18 years ago
Verified fixed in 1999-08-30-09-M10 Mac bld.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.