Investigate if events dispatched to XHR and XHR.upload are dispatched in the order specified in XMLHttpRequest v2

RESOLVED DUPLICATE of bug 908375

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 908375
7 years ago
4 years ago

People

(Reporter: smaug, Assigned: smaug)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

...since I think that is not always the case.
Seems like we sometimes dispatch first to XHR and then to upload and
the current XHR v2 draft says it should happen first upload and then XHR.
Don't know if the draft has just changed at some point...

Comment 2

4 years ago
Anyone investigated this?

Chromium received the same bug report and going to make it conform to the latest spec.
https://code.google.com/p/chromium/issues/detail?id=264609
The reporter said Firefox is following the old spec.
I think this is better tracked by bug 908375 (nearby: bug 918770), since I'm linking to the XHR test suite's send-response-event-order.htm from that bug..
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 908375
You need to log in before you can comment on or make changes to this bug.